bugWarzone 2100 Project - Bugs: bug #12314, please do not add embedded code...

Show feedback again

You are not allowed to post comments on this tracker with your current authentification level.

bug #12314: please do not add embedded code copies (sqllite)

Submitted by:  Paul Wise <pabs>
Submitted on:  Mon Sep 15 08:22:52 2008  
Category: Build systemSeverity: Important
Priority: 5 - NormalStatus: None
Assigned to: NoneOpen/Closed: Open
Release: svn/trunkOperating System: GNU/Linux
Planned Release: None

Wed Sep 17 07:29:39 2008, comment #3:

Debian lenny (upcoming stable release) has sqlite3 3.5.9 and lua 5.1.3. Debian etch has sqlite3 3.3.8 and lua 5.1.1. Ubuntu hardy (last release) has sqlite3 3.4.2 and lua 5.1.2. Fedora 9 (last release) has sqlite 3.5.9 and lua 5.1.4. Gentoo has sqlite 3.5.9/3.6.2 and lua 5.1.3-r4.

Just depend on the version you need and the distributions will upgrade their sqlite packages as needed.

For Windows and Mac you don't need to embed these libraries into SVN or release tarballs.

If you need patches to libraries, get those patches integrated into the libraries upstream, then check for the required versions, functions or behaviour in configure.ac and be done with it.

Paul Wise <pabs>
Mon Sep 15 18:50:38 2008, comment #2:

3.5.9 should be stable on most distros. It is also unpatched (as opposed to the 3.5.?6? we were using before, which incorporated some bugfixes from 3.5.[789]).
On Windows we have the devpkg, on OSX XCode could possible download it as it does for all the other stuff.

As we are at this: Embedding Lua: It will be afaik also unpatched, and most distros should ship a fairly recent version like 5.1.3, right?

If that reasoning has no mistakes, I'd agree with Paul...

Dennis Schridde <devurandom>
Project Administrator
Mon Sep 15 09:44:20 2008, comment #1:

It is my understanding that the use of the embedded version of SQLite is currently a configure option with it being possible to use the systems version.

Is this not the case? The purpose behind embedding was for the benefit of OS X and Windows — the former coming with a rather old version and the latter not shipping it at all.

I also believe that our custom VFS API requires some of the features present only in the most recent versions of SQLite — versions that might not be main stream.

Freddie Witherden <evilguru>
Project Member
Mon Sep 15 08:22:52 2008, original submission:

It is generally a bad idea to add embedded code copies. It would be great if you could remove sqllite from SVN and depend on the required versions of sqllite and fail to configure/build if it isn't present. If there is some patch/behaviour that is required from sqllite, please test for that in configure. Linux distros need to be able to upgrade packages and have that change reliably affect all packages using the upgraded packages, warzone included.

Paul Wise <pabs>


No files currently attached


Depends on the following items: None found

Items that depend on this one: None found


Carbon-Copy List
  • -unavailable- added by devurandom (Posted a comment)
  • -unavailable- added by evilguru (Posted a comment)
  • -unavailable- added by pabs (Submitted the item)

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.


    Error: not logged in



    No Changes Have Been Made to This Item
    Show feedback again

    Back to the top

    Powered by Savane 3.1-cleanup