bugBattle for Wesnoth - Bugs: bug #13878, [Mac]Cannot change languages more...

 
 
Show feedback again

bug #13878: [Mac]Cannot change languages more than once

Submitted by:  ancestral <ancestral>
Submitted on:  Mon Jul 6 08:56:22 2009  
 
Category: BugSeverity: 3 - Normal
Priority: 5 - NormalItem Group: User Interface
Status: ConfirmedPrivacy: Public
Assigned to: Simon Forsyth <alarantalara>Open/Closed: Open
Release: 1.6+Operating System: 10.4.11, 10.5.7

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Tue May 24 03:31:22 2016, comment #11:

Issue remains in 1.12.6, but confirmed it's resolved in 1.13.x. We need to figure out what fixed this so we can backport.

ancestral <ancestral>
Project Member
Thu Feb 4 06:49:42 2016, comment #10:

Issue now appears fixed in 1.13 (and I think 1.12 too).

ancestral <ancestral>
Project Member
Mon Apr 30 03:12:48 2012, comment #9:

Issue appears unfixed in 1.10.1 while running OS X 10.7.3, same exact behavior as before.

ancestral <ancestral>
Project Member
Thu Oct 20 20:40:55 2011, comment #8:

another report here: bug #16910
(basically the required confirmation)

Anonymissimus <anonymissimus>
Project Member
Mon Mar 8 17:54:14 2010, comment #7:

Issue appears unfixed in 1.7.13 while running OS X 10.6.2, same exact behavior as before.

Tried rebuilding cache immediately afterwards, F5, but this doesn’t fix it either.

ancestral <ancestral>
Project Member
Fri Oct 2 19:28:59 2009, SVN revision 39037:

Assign all members in operator=.

cppcheck discovered a missing one, found more and fixed all operators=.
(This fix might also fix bug #13878, but not tested).

(Browse SVN revision 39037)

Mark de Wever <mordante>
Project Member
Wed Sep 30 20:59:32 2009, comment #5:

As you informed me on IRC you are running Linux; however, this is a Mac OS X/Wesnoth specific issue.

I'd appreciate it if anyone else running Mac OS X could test this, just to confirm it's not just me. At which point, if another person can, can the status be changed to "Confirmed"?

ancestral <ancestral>
Project Member
Wed Sep 30 19:37:29 2009, comment #4:

Yes, I committed a patch, not for this particular issue, but for a more general issue involving strings not being changed when language was changed. And as far as I'm concerned, I can't reproduce the issue: I can change languages several times in a row and buttons are properly updated.

Guillaume Melquiond <silene>
Wed Sep 30 19:24:59 2009, comment #3:

With 1.7.6 the issue still persists. Was there a patch that fixed the issue? silene, if you know more information I'd be interested please.

ancestral <ancestral>
Project Member
Mon Jul 6 12:35:51 2009, comment #2:

Problems with buttons are being worked on, so please don't submit them as bugs for now.

Karol Nowak <grzywacz>
Project Member
Mon Jul 6 09:05:39 2009, comment #1:

This appears to be OS specific as 1.6.2 for Windows works fine. However, there is a graphical issue with languages that have words of varying length compared to the previous language chosen, causing the drawing the buttons on the main menu screen to look a little distorted. I'm not sure if this is a known issue being fixed [later?] or if this should require a new bug submission.

Thanks.

ancestral <ancestral>
Project Member
Mon Jul 6 08:56:22 2009, original submission:

If you change the language more than once, you do not see the changes. In other words, you cannot change languages more than once.

1. Click "Languages" from the main menu.
2. Click another language and click "OK". Notice the language of the buttons have changed (assuming the language has a translation for them).
3. Click "Languages" (likely in another language!) from the main menu.
4. Click another language and click "OK". Notice the language of the buttons has not changed.

If I choose a language without a full translation and then choose a full one you will see some language updated, so it's almost like it's not allowing text to be replaced that has already been replaced before.

Quitting Wesnoth and re-opening correctly draws the last language chosen.

Erasing preferences and cache files does not resolve this issue other than it reverts to the system default.

I have been able to reproduce this with:

1.6.0, Mac OS X 10.4.11
1.6.3, Mac OS X 10.5.7
1.7.1, Mac OS X 10.5.7

ancestral <ancestral>
Project Member

 

(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by vultraz (Updated the item)
  • -unavailable- added by fendrin (Updated the item)
  • -unavailable- added by anonymissimus (Posted a comment)
  • -unavailable- added by mordante (Updated the item)
  • -unavailable- added by silene (Updated the item)
  • -unavailable- added by esr (Updated the item)
  • -unavailable- added by grzywacz (Posted a comment)
  • -unavailable- added by ancestral (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Error: not logged in

     

     

    Follow 13 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Tue May 24 05:20:00 2016ancestralOpen/ClosedClosed=>Open
    Tue May 24 03:31:22 2016ancestralStatusFixed=>Confirmed
    Sat Mar 5 13:13:36 2016vultrazOpen/ClosedOpen=>Closed
    Thu Feb 4 06:49:42 2016ancestralStatusIn Progress=>Fixed
    Tue Oct 25 16:28:55 2011fendrinAssigned toNone=>alarantalara
    Thu Oct 20 20:40:55 2011anonymissimusAssigned tosilene=>None
      SummaryCannot change languages more than once=>[Mac]Cannot change languages more than once
    Mon Mar 8 17:56:58 2010mordanteStatusFixed=>In Progress
    Mon Mar 8 17:56:10 2010mordanteOpen/ClosedClosed=>Open
    Tue Sep 29 19:58:32 2009sileneStatusNone=>Fixed
      Assigned tomordante=>silene
      Open/ClosedOpen=>Closed
    Mon Jul 6 15:49:24 2009esrAssigned toNone=>mordante
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup