bugFreeciv - Bugs: bug #14522, Crash connecting to network game

 
 
Show feedback again

bug #14522: Crash connecting to network game

Submitted by:  Jeremy Jacko <jbfrog>
Submitted on:  Wed 14 Oct 2009 11:21:23 AM UTC  
 
Category: generalSeverity: 3 - Normal
Priority: 5 - NormalStatus: Fixed
Assigned to: pepeto <pepeto>Open/Closed: Closed
Release: Operating System: None
Planned Release: 2.1.12, 2.2.0

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Tue 26 Jan 2010 04:20:40 PM UTC, SVN revision 16625:

Never exit Freeciv when loading a file by the registry module. Remove the
function inf_token_required().

Reported by Jeremy Jacko (jbfrog) for the metaserver answer

See gna bug #14522

(Browse SVN revision 16625)

pepeto <pepeto>
Project MemberIn charge of this item.
Tue 26 Jan 2010 04:20:39 PM UTC, SVN revision 16624:

Never exit Freeciv when loading a file by the registry module. Remove the
function inf_token_required().

Reported by Jeremy Jacko (jbfrog) for the metaserver answer

See gna bug #14522

(Browse SVN revision 16624)

pepeto <pepeto>
Project MemberIn charge of this item.
Tue 26 Jan 2010 04:20:36 PM UTC, SVN revision 16623:

Never exit Freeciv when loading a file by the registry module. Remove the
function inf_token_required().

Reported by Jeremy Jacko (jbfrog) for the metaserver answer

See gna bug #14522

(Browse SVN revision 16623)

pepeto <pepeto>
Project MemberIn charge of this item.
Fri 18 Dec 2009 10:06:05 AM UTC, comment #8:

So both servers and clients freeze when there is maintenance break in metaserver.

Metaserver will move during either 2Q2010 or 3Q2010 and there will be longish break when it does not work. This bug should be fixed, and version with the fix released, before that.

Marko Lindqvist <cazfi>
Project Administrator
Thu 15 Oct 2009 12:39:15 PM UTC, comment #7:

> Nevertheless, I also observed that attempt to connect to
> metaserver blocks client for some time when there is no
> connection to Internet (probably dns query).


The same occurs in server side unfortunately. When the metaserver have some problems the server freezes.

Also, the server freezes when a new connection is accepted due to the synchronous host name request.

pepeto <pepeto>
Project MemberIn charge of this item.
Thu 15 Oct 2009 12:27:40 PM UTC, comment #6:

As I were without Internet connection for some time, I know that being completely unable to connect metaserver does not crash the client. In that case there is no reply at all, so client cannot crash trying to parse it. With wrong http_proxy there is http reply which client cannot parse.

Nevertheless, I also observed that attempt to connect to metaserver blocks client for some time when there is no connection to Internet (probably dns query).

Marko Lindqvist <cazfi>
Project Administrator
Thu 15 Oct 2009 12:10:26 PM UTC, comment #5:

> Shouldn't it be possible to join a LAN game even if the LAN is
> not connected to the internet?


I made a new ticket for that (bug #14529).

pepeto <pepeto>
Project MemberIn charge of this item.
Thu 15 Oct 2009 11:56:05 AM UTC, comment #4:

The client is working now, though the issue was not with the default_metaserver setting, which pointed to "http://www.cazfi.net/freeciv/metaserver/" by default. I had neglected to set the http_proxy in the windows shell prior to running civclient. After setting this, the client operates as expected. This was my error, but it doesn't make sense to me that the client would crash because it can't connect to the metaserver. Shouldn't it be possible to join a LAN game even if the LAN is not connected to the internet?

Jeremy Jacko <jbfrog>
Wed 14 Oct 2009 08:46:22 PM UTC, comment #3:

As far as I know, lan server list is not got using the registry module. It is linked with the metaserver string. I tried to connect the metaserver "http://forum.freeciv.org" and I got the same crash.

Could you post here what prints the command

Changing this string to http://meta.freeciv.org/metaserver.phtml would fix your problem. But anyway, I don't think the client should crash for that.

pepeto <pepeto>
Project MemberIn charge of this item.
Wed 14 Oct 2009 11:43:50 AM UTC, comment #2:

I have tried with and without the server running, and with and without the Windows firewall enabled. None of this seems to make any difference.

Jeremy Jacko <jbfrog>
Wed 14 Oct 2009 11:38:06 AM UTC, comment #1:

Does it happen also when there is no server running on the LAN or not?

- Cazfi

Anonymous
Wed 14 Oct 2009 11:21:23 AM UTC, original submission:

I am trying to use the windows client (2.1.9-gtk2) to connect to a linux server running on the LAN. When I click the "Connect to Network Game" button, the network connection window appears very briefly, but then the program closes with no on-screen error messages. The stderr.txt file in the freeciv program folder gives the message "0: Did not find token entry_name in (null) line 1".
I have found a few old references to this problem online, suggesting that the "default_metaserver=" line should be removed from .civclientrc (see http://www.mail-archive.com/freeciv-dev@gna.org/msg03350.html), but this did not help in my case. I have tried uninstalling freeciv and removing all related config files and folders, but upon reinstallation the problem persists. The SDL client works correctly on the same machine. I am attaching the stderr.txt file produced with the "-d 3" command line option.

Jeremy Jacko <jbfrog>

 

(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files
file #6991:  stderr.txt added by jbfrog (7kB - text/plain - This is the -d 3 stderr file)
file #6990:  stderr.txt added by jbfrog (51B - text/plain)

 

Depends on the following items: None found

Digest:
   bug dependencies.

 

Carbon-Copy List
  • -unavailable- added by cazfi (Posted a comment)
  • -unavailable- added by pepeto (Posted a comment)
  • -unavailable- added by jbfrog (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 13 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Tue 26 Jan 2010 04:21:00 PM UTCpepetoStatusReady For Test=>Fixed
      Open/ClosedOpen=>Closed
    Sat 23 Jan 2010 07:29:51 PM UTCpepetoDependencies-=>bugs #15191 is dependent
    Sat 23 Jan 2010 06:13:25 PM UTCpepetoAttached File-=>Added trunk_inf_token_required.diff, #7767
      Attached File-=>Added S2_2_S2_1_inf_token_required.diff, #7768
      StatusConfirmed=>Ready For Test
      Assigned toNone=>pepeto
      Planned Release2.2.0=>2.1.12, 2.2.0
    Fri 18 Dec 2009 10:06:05 AM UTCcazfiCategoryclient-gtk-2.0=>general
      Planned Release=>2.2.0
    Wed 14 Oct 2009 08:46:22 PM UTCpepetoStatusNone=>Confirmed
    Wed 14 Oct 2009 11:27:52 AM UTCjbfrogAttached File-=>Added stderr.txt, #6991
    Wed 14 Oct 2009 11:21:23 AM UTCjbfrogAttached File-=>Added stderr.txt, #6990
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup