bugWkCMake - Bugs: bug #15082, Single-Configuration generator...

 
 
Show feedback again

You are not allowed to post comments on this tracker with your current authentification level.

bug #15082: Single-Configuration generator -> build type not take in account unless clean cache

Submitted by:  Alexandre VINCENT <asmodehn>
Submitted on:  Sat 09 Jan 2010 06:04:18 PM UTC  
 
Category: NoneSeverity: 2 - Minor
Priority: 1 - LaterStatus: Need Info
Privacy: PublicAssigned to: None
Open/Closed: Open

Sat 09 Jan 2010 06:04:18 PM UTC, original submission:

On Single configuration generator, such as make, when building a project. it seems that the first generation of the project gives the expected result for BUILD_TYPE. However if someones change the BUILD_TYPE value after the project has been generated once, it doesnt affect the generated project at all.

A cache clean seems to be needed to regenarate a project with a different build_type...

Is it a cmake problem or a strange problem in WkCMAke, playing with values in cache ?

Alexandre VINCENT <asmodehn>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by asmodehn (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    No Changes Have Been Made to This Item
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup