bugMyPaint - Bugs: bug #15566, [OSX] Colorpicker always picks...

 
 
Show feedback again

You are not allowed to post comments on this tracker with your current authentification level.

bug #15566: [OSX] Colorpicker always picks black

Submitted by:  Jon Nordby <jonnor>
Submitted on:  Tue Mar 9 18:39:56 2010  
 
Severity: 3 - NormalPriority: 5 - Normal
Status: Need InfoPrivacy: Public
Assigned to: NoneOpen/Closed: Open
Release: 0.8Planned Release: None
Operating System: MacOSX

(Jump to the original submission Jump to the original submission)

Mon Jun 23 18:39:58 2014, comment #9:

Hi - can anyone confirm whether this is happening with the latest git master? If not, We'll have to close this bug since we're now migrating bug tracker reports over to github.

(I consider the color picker code on master to have a workaround for this issue now, but I don't have access to OSX, so I am unable to test it myself. Your help would be appreciated.)

This bug tracker will shortly be moving to github.
As part of this process,
we're reviewing old bug reports on gna.org.
Please respond so that we know this bug is still live.

Andrew Chadwick <achadwick>
Project Administrator
Sun Dec 2 01:32:16 2012, comment #8:

This might be fixed by the experimental workaround in https://gitorious.org/mypaint/mypaint/commit/f38b4b8a52e7f679853992424b8d5cd985efec9c. I'm not able to reproduce this right now on my system (native Debian testing/Wheezy, under Gnome3 or Xfce4; Virtualbox guest Ubuntu 12.10 under Unity) with Intel video hardware, but it seems plausible .

Please could everyone test against the latest git and report back here or on bug #20311? If you're bitten by this bug, hopefully you'll find that picking still doesn't work on non-MyPaint windows, but that it's fixed on MyPaint's own canvases, toolbars and buttons.

Would be interested if you see the colour picker pick pure #ff0000 red anywhere it shouldn't. I've improved the error checking, and I'm using that colour as a flag for when grabbing areas of the screen to a pixbuf before sampling/averaging fails in a detectable way. It won't be enough to fix this everywhere, but it should allow us to distinguish between fail cases.

Andrew Chadwick <achadwick>
Project Administrator
Sun Aug 14 21:00:54 2011, comment #7:

Duplicate: bug #18505

Jon Nordby <jonnor>
Project Administrator
Sun Apr 18 01:00:58 2010, comment #6:

One last thing on this topic. Would it be possible to incorporate some alternate color picker tool other than the one built into the GTK color selector window for the time being? Maybe one that picks the color from only the canvas area? Maybe this would be too much work to be worth it. What do you guys think?

Kevin <rocwiff>
Sat Apr 10 17:02:25 2010, comment #5:

Bug filed with GTK+
https://bugzilla.gnome.org/show_bug.cgi?id=615366

Kevin <rocwiff>
Wed Apr 7 14:46:05 2010, comment #4:

In GTK+ or in X11.app. GTK+ people will probably know more in any case; http://www.gtk.org/development.html

Jon Nordby <jonnor>
Project Administrator
Wed Apr 7 12:47:45 2010, comment #3:

Ok, I tested the color picker on the GTK color triangle window by selecting colors on a Gimp window. The same problem remains. I guess this means that it's a GTK+ bug? If so then i'll file a bug with GTK+. Could you point me to the bug tracker for GTK+? Thanks.

Kevin <rocwiff>
Mon Apr 5 16:16:17 2010, comment #2:

A quick search over gtk+ bugreports did not show anything. If you want to help, test and see if the color picker (the one that can choose colors from any part of the screen, eg. in the gtk triangle color selector) works as expected in other GTK applications. If not, fill a bugreport against gtk with all the information.

Martin Renold <martinxyz>
Project Administrator
Mon Apr 5 15:22:49 2010, comment #1:

I can confirm this issue. For me running Mypaint v0.8.2 under OSX 10.6.2, the color picker seems to be picking the wrong shade of color. It seems to default to picking a very dark shade of color even when selecting very light or even white shades. I think some are interpreting it as selecting only black, because it usually selects a very dark or black shade. This behavior is also present when using the color picker on the brush and layer tool windows and even native OSX apps. Hopefully a solution to this issue can be found as it is a serious usability problem for OSX users.

Kevin <rocwiff>
Tue Mar 9 18:39:56 2010, original submission:

When using MyPaint with X.app on OSX the color picker always picks black. This happens when invoked from the gtk.ColorSelector dialog, when using the keyboardshortcut or when using ctrl+button1.

This might be due to a bug or limitation in the OSX X server implementation or in GTK.

Jon Nordby <jonnor>
Project Administrator

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by achadwick (Posted a comment)
  • -unavailable- added by martinxyz (Posted a comment)
  • -unavailable- added by rocwiff (Posted a comment)
  • -unavailable- added by jonnor (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Error: not logged in

     

     

    Follow 3 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Mon Jun 23 18:39:58 2014achadwickStatusConfirmed=>Need Info
    Tue Sep 14 17:32:38 2010martinxyzOperating System=>MacOSX
    Mon Apr 5 16:16:17 2010martinxyzStatusNone=>Confirmed
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup