bugBattle for Wesnoth - Bugs: bug #15567, Default hotkey for Mute (ctrl-alt...

 
 
Show feedback again

bug #15567: Default hotkey for Mute (ctrl-alt m) doesn't work

Submitted by:  Max <max2008>
Submitted on:  Tue 09 Mar 2010 07:03:13 PM UTC  
 
Category: BugSeverity: 3 - Normal
Priority: 5 - NormalItem Group: User Interface
Status: NonePrivacy: Public
Assigned to: Anonymissimus <anonymissimus>Open/Closed: Open
Release: 1.7.11Operating System: XP, Win7

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Thu 13 Aug 2015 01:34:03 PM UTC, comment #5:

Turns out it's not related to Ctrl+m characters. It's related to the apparent inability to read Ctrl+Alt+[key] combinations from the default hot-keys in /data/core/hotkeys.cfg. This can be confirmed by attempting to add a custom hot-key of Ctrl+Alt+m - the game will not complain that it's already in use. In fact, as a work-around, one can manually add Ctrl+Alt+m as a hot-key for mute in order for it to work.

The only other default Ctrl+Alt combination is Repeat Recruit, which is Ctrl+Alt+r. This also does not work by default, but can be added manually as a work-around.

Wedge009 <wedge009>
Thu 13 Aug 2015 11:44:18 AM UTC, comment #4:

I wonder if this is related to something I'm investigating at the moment, which is that Ctrl+Enter is not detected correctly. Instead (depending on operating system, and therefore the EOL format used), it is detected as Ctrl+j or Ctrl-m, which correspond to LF and CR characters. This seems to be related to the choice to use 'character' instead of 'key code' to read keyboard input for the sake of being able to have something like (for example) Ctrl+M instead of Ctrl+Shift+m.

Wedge009 <wedge009>
Fri 21 Nov 2014 11:16:59 PM UTC, comment #3:

removed a leading space in the bug description.

Daniel <gfgtdf>
Project Member
Thu 01 Dec 2011 03:32:25 PM UTC, comment #2:

see also bug #18868, bug #19084

Anonymissimus <anonymissimus>
Project MemberIn charge of this item.
Wed 26 Oct 2011 03:49:04 PM UTC, comment #1:

In case someone wonders why this is assigned to me: It is a win-only problem and I have suspicions about the cause.

Anonymissimus <anonymissimus>
Project MemberIn charge of this item.
Tue 09 Mar 2010 07:03:13 PM UTC, original submission:

Problem exists in every single version i've tried so far (1.6 up to latest 1.7). OS: xp, win7.

I'm also unable to set any ctrl-alt hotkey:
ctrl-alt-m results in a reset of the hotkey
ctrl-alt-q = ctrl-alt-@
ctrl-alt-w,e,r,t,... = ctrl-alt-`

once i set e.g. ctrl-alt-w it works (but for e, r, t and other keys as well).

here's a log (--log-debug=all) of following actions:
- deleted userdata folder
- tried ctrl-alt-m twice on the main screen
- open preferences dialog
- set hotkey to ctrl-alt m (hotkey is blank afterwards)
- set hokey to ctrl-alt i (shows as ctrl-alt `)
- back to main screen and tried ctr-alt i (followed by some other keys)

Max <max2008>

 

(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by wedge009 (Posted a comment)
  • -unavailable- added by gfgtdf (Updated the item)
  • -unavailable- added by anonymissimus (Posted a comment)
  • -unavailable- added by max2008 (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 2 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Fri 21 Nov 2014 11:16:11 PM UTCgfgtdfSummary Default hotkey for Mute (ctrl-alt m) doesn\'t work=>Default hotkey for Mute (ctrl-alt m) doesn't work
    Thu 11 Aug 2011 02:39:04 PM UTCanonymissimusAssigned toNone=>anonymissimus
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup