bugBattle for Wesnoth - Bugs: bug #16820, [kill] with fire_event=yes doesn't...

Show feedback again

bug #16820: [kill] with fire_event=yes doesn't trigger end of scenario

Submitted by:  Lari Nieminen <zookeeper>
Submitted on:  Tue 05 Oct 2010 08:22:00 AM UTC  
Votes:  10  
Category: Feature RequestSeverity: 3 - Normal
Priority: 5 - NormalItem Group: WML
Status: Wont FixPrivacy: Public
Assigned to: NoneOpen/Closed: Closed
Release: trunkOperating System: all

Add a New Comment (Rich MarkupRich Markup):

You are not logged in

Please log in, so followups can be emailed to you.


Sun 09 Nov 2014 05:38:20 PM UTC, comment #4:

Does (and should) not invoke the end of the scenario becasue in the same event (or rather in the same user action (here:'move')) the WML might give the sides the units back s that they have leaders at the end of the move. If you want to make sure to invoke a victory/defeat use [endlevel].

The code has been changed to perform a check_victory after every user action (especialy after every move) so the case posted in the first post will now lead to a defeat immidiately unless there are some other moveto events which do other stuff to prevent it.

Daniel <gfgtdf>
Project Member
Sun 12 Dec 2010 05:13:40 AM UTC, comment #3:

The patch is patch 2241:


Dr. Robert Marmorstein <atomopawn>
Sat 11 Dec 2010 09:36:53 PM UTC, comment #2:

There is a patch for this on the patch board. Will it be included in the next release?

Dr. Robert Marmorstein <atomopawn>
Sun 10 Oct 2010 11:31:59 AM UTC, comment #1:

Switching to feature request, since firing events (whether in [kill] or elsewhere) has never triggered the end of a scenario. So this would be a change of semantic for events. (Not that it is a bad idea, just that it is not a bug.)

Guillaume Melquiond <silene>
Tue 05 Oct 2010 08:22:00 AM UTC, original submission:

When a player side's leader is [kill]ed with fire_event=yes, the scenario doesn't end even though it would have if an enemy unit had killed it in combat.

So, when [kill] is used with fire_event=yes, the game should check for leader-based victory/defeat in exactly the same manner as it does when a unit kills another in regular combat.

Lari Nieminen <zookeeper>
Project Member


(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):

No files currently attached


Depends on the following items: None found

Items that depend on this one: None found


Carbon-Copy List
  • -unavailable- added by shadowmaster (Updated the item)
  • -unavailable- added by gfgtdf (Posted a comment)
  • -unavailable- added by atomopawn (Posted a comment)
  • -unavailable- added by atomopawn (Voted in favor of this item)
  • -unavailable- added by silene (Posted a comment)
  • -unavailable- added by zookeeper (Submitted the item)

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 10 encouragements so far.

    Only logged-in users can vote.


    Please enter the title of George Orwell's famous dystopian book (it's a date):



    Follow 6 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Mon 10 Nov 2014 12:05:23 AM UTCshadowmasterStatusFixed=>Wont Fix
    Sun 09 Nov 2014 05:38:20 PM UTCgfgtdfStatusNone=>Fixed
    Sat 11 Dec 2010 09:36:02 PM UTCatomopawnCarbon-Copy-=>Added atomopawn
    Sun 10 Oct 2010 11:31:59 AM UTCsileneCategoryBug=>Feature Request
    Tue 05 Oct 2010 08:22:21 AM UTCzookeeperSummary[end_turn] skips linger mode=>[kill] with fire_event=yes doesn't trigger end of scenario
    Show feedback again

    Back to the top

    Powered by Savane 3.1-cleanup