bugMyPaint - Bugs: bug #18947, Color Picker doesn't work on a...

 
 
Show feedback again

You are not allowed to post comments on this tracker with your current authentification level.

bug #18947: Color Picker doesn't work on a secondary screen

Submitted by:  grubert <grubert>
Submitted on:  Mon 07 Nov 2011 08:06:57 AM UTC  
 
Severity: 2 - MinorPriority: 5 - Normal
Status: ConfirmedPrivacy: Public
Assigned to: NoneOpen/Closed: Open
Release: mypaint-git-061111Planned Release: None
Operating System: Windows Vista

Sun 02 Dec 2012 01:32:45 AM UTC, comment #4:

This might be fixed by the experimental workaround in https://gitorious.org/mypaint/mypaint/commit/f38b4b8a52e7f679853992424b8d5cd985efec9c. I'm not able to reproduce this right now on my system (native Debian testing/Wheezy, under Gnome3 or Xfce4; Virtualbox guest Ubuntu 12.10 under Unity) with Intel video hardware, but it seems plausible .

Please could everyone test against the latest git and report back here or on bug #20311? If you're bitten by this bug, hopefully you'll find that picking still doesn't work on non-MyPaint windows, but that it's fixed on MyPaint's own canvases, toolbars and buttons.

Would be interested if you see the colour picker pick pure #ff0000 red anywhere it shouldn't. I've improved the error checking, and I'm using that colour as a flag for when grabbing areas of the screen to a pixbuf before sampling/averaging fails in a detectable way. It won't be enough to fix this everywhere, but it should allow us to distinguish between fail cases.

Andrew Chadwick <achadwick>
Project Administrator
Tue 20 Nov 2012 01:55:49 PM UTC, comment #3:

Bug #17076 is a duplicate of this (and confirms it: same OS, same issue). Probably it is an upstream issue, but perhaps we can be smarter about what we do with picking too, to make GTK bugs around colour picking less painful to users. Would be nice if it at least worked on the canvas...

Andrew Chadwick <achadwick>
Project Administrator
Thu 29 Dec 2011 08:32:04 PM UTC, comment #2:

ok, two months later,
I understood how to report in bugtrackers :
https://bugzilla.gnome.org/show_bug.cgi?id=666940

grubert <grubert>
Mon 07 Nov 2011 09:36:23 PM UTC, comment #1:

Grubert, I can't find this issue in gtk bugreport.
https://bugzilla.gnome.org/buglist.cgi?quicksearch=Color+Picker

If this a GTK+ issue, would you mind to report it in the bugtracker? there is already a bug about color picker in win32 so it may be a good chance this bug may get fixed too. Thanks

Bakhtiar <tumagonx>
Project Administrator
Mon 07 Nov 2011 08:06:57 AM UTC, original submission:

The color picker doesn't pick color ( only black ) on a secondary screen.
This problem is here since version O.9

And, with the same machine under Linux, the problem is no more...

grubert <grubert>

 

Attached Files

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by achadwick (Posted a comment)
  • -unavailable- added by tumagonx (Posted a comment)
  • -unavailable- added by grubert (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 3 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Tue 20 Nov 2012 01:55:49 PM UTCachadwickSeverity4 - Important=>2 - Minor
      StatusNone=>Confirmed
    Mon 07 Nov 2011 08:06:57 AM UTCgrubertAttached File-=>Added MyPaintCaptureMultiscreen.jpg, #14463
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup