bugFreeciv - Bugs: bug #19840, Multicast fails without active...

 
 
Show feedback again

bug #19840: Multicast fails without active connection

Submitted by:  Zakri Kneebone <i1abnrk>
Submitted on:  Sat 23 Jun 2012 02:56:13 PM UTC  
 
Category: bootstrapSeverity: 3 - Normal
Priority: 5 - NormalStatus: None
Assigned to: NoneOpen/Closed: Open
Release: 2.4.99Operating System: GNU/Linux
Planned Release: 

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sun 12 Oct 2014 01:39:33 PM UTC, comment #5:

(It also happens on my netbook when I have no physical connectivity at all -- network cable unplugged and no wireless. This is more like the OP's setup, and perhaps more forgivable, although it might still be nice if server/client both on localhost could find each other. For more details of my setup see bug #22792.)

Jacob Nevins <jtn>
Project Administrator
Sun 12 Oct 2014 01:37:00 PM UTC, comment #4:

Confirm this can still happen with S2_4 r26761.

In my case I took away internet connectivity (via ppp0) but still had an active physical connection to a local network via eth0, and it had another machine on it. This is a scenario that ought to work correctly.

Jacob Nevins <jtn>
Project Administrator
Tue 11 Mar 2014 09:39:10 PM UTC, comment #3:

See also bug #18440.

Jacob Nevins <jtn>
Project Administrator
Sat 23 Jun 2012 05:17:40 PM UTC, comment #2:

Correct, clicking connect with localhost:5556 works. I was confused because of the output and I'm used to selecting localhost from the lan selection pane.

Zakri Kneebone <i1abnrk>
Sat 23 Jun 2012 04:45:04 PM UTC, comment #1:

> 1: IP_ADD_MEMBERSHIP (225.1.1.1) failed: No such device


> But the UDP error prevents local/virtual game play without an
> active connection.


That broadcast is used only to announce games in local network, it shouldn't affect actual play once you know server name ('localhost') and port ('5556' by default) to connect to.

Marko Lindqvist <cazfi>
Project Administrator
Sat 23 Jun 2012 02:56:13 PM UTC, original submission:

Trying to set up a network game without an active physical connection I was stopped by a UDP/Multicast failure. Server said:

1: IP_ADD_MEMBERSHIP (225.1.1.1) failed: No such device

but rulesets still loaded, however connecting with same client (gtk3) I receive:

1: lanserver scan sendto failed: Network is unreachable
1: Error connecting to metaserver

The second one is normal and I can still play the game without a metaserver. But the UDP error prevents local/virtual game play without an active connection.
I'm not sure if this is the correct category for submission.

Zakri Kneebone <i1abnrk>

 

(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Digest:
   patch dependencies.

 

Carbon-Copy List
  • -unavailable- added by jtn (Posted a comment)
  • -unavailable- added by cazfi (Posted a comment)
  • -unavailable- added by i1abnrk (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    No Changes Have Been Made to This Item
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup