bugFreeciv - Bugs: bug #19893, Build from tarball requires same...

 
 
Show feedback again

bug #19893: Build from tarball requires same libtool version that was used while running autogen.sh

Submitted by:  Marko Lindqvist <cazfi>
Submitted on:  Tue Jul 3 18:31:05 2012  
 
Category: bootstrapSeverity: 3 - Normal
Priority: 5 - NormalStatus: Duplicate
Assigned to: Marko Lindqvist <cazfi>Open/Closed: Closed
Release: Operating System: None
Planned Release: Contains string changes: None

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Sun Oct 2 19:59:08 2016, comment #12:

Together all the fixes already committed should have fixed this. At least that's what comment #7 : "Yes, that's how I eventually managed to get my build going" implies about them.

Marko Lindqvist <cazfi>
Project AdministratorIn charge of this item.
Wed Feb 24 01:27:26 2016, comment #11:

libtoolize with 'copy' -> patch #7001

Marko Lindqvist <cazfi>
Project AdministratorIn charge of this item.
Tue Jan 26 10:10:38 2016, comment #10:

> Once libtoolize gets run after aclocal, aclocal needs to be run again


-> patch #6861

Marko Lindqvist <cazfi>
Project AdministratorIn charge of this item.
Sat Jul 7 00:43:34 2012, comment #9:

They are not symlinks in tarball. It's probably automake that takes care of that.

Marko Lindqvist <cazfi>
Project AdministratorIn charge of this item.
Sat Jul 7 00:39:04 2012, comment #8:

Honestly ?
only files belong into tarball - symlinks might for one or other reason be invalid.

Well, just my opinion.

Anonymous
Fri Jul 6 22:11:13 2012, comment #7:

> Does it work if you use "libtoolize -c -f" instead ?


Yes, that's how I eventually managed to get my build going. Not sure if we should use that in autogen.sh...

Marko Lindqvist <cazfi>
Project AdministratorIn charge of this item.
Fri Jul 6 22:02:11 2012, comment #6:

Does it work if you use "libtoolize -c -f" instead ?

Anonymous
Fri Jul 6 21:20:14 2012, comment #5:

The libtoolize bug I referred to is the fact that "libtoolize -f" does not update m4 in my specific use case. Nothing to do with autogen.sh really, as I've not even used it in my latest tests but just "libtoolize -f" and "aclocal -I m4 -I dependencies/m4" directly.

Yes, we should still change aclocal to run (also) after libtoolize in autogen.sh, but with that libtoolize bug it would't help as libtoolize really does nothing.

Marko Lindqvist <cazfi>
Project AdministratorIn charge of this item.
Fri Jul 6 20:30:27 2012, comment #4:

No.
Again, right now autogen.sh works (in this regard) like this on such generated tarball:
aclocal runs - it uses macros from m4/; aclocal.m4 gets generated
libtoolize runs - ltmain.sh and macros in m4/ are updated

...but that doesn't update aclocal.m4 generated by aclocal.
Anyway, autoreconf proves it's the expected behavior.

With a recent enough automake it wouldn't probably matter as those m4_include macros in such dirs, but IIRC, that's only since automake 1.11.
...
Wait, now that I think about it point 4 doesn't make sense, unless either timestamps are messed up or you force regeneration of configure script.
Could you explain a bit more ?

Anonymous
Fri Jul 6 18:52:23 2012, comment #3:

There is "-f" passed to libtoolize in our autogen.sh after all, it just doesn't work under the circumstances. I think I've got bug to file against libtool.

Marko Lindqvist <cazfi>
Project AdministratorIn charge of this item.
Wed Jul 4 11:40:59 2012, comment #2:

Well, a part of the problem lies in autogen.sh script - it's just not complicated enough ;)
Once libtoolize gets run after aclocal, aclocal needs to be run again (see autoreconf - that script does a bit too much in some places, not enough in the others, but in this case is quite clear).
Also, as AC_CONFIG_MACRO_DIR is set and autogen.sh uses 'libtoolize -f' the macros should be overwritten.

Does the failure still happen after applying above fix ?
If so, could you attach the log.

Anonymous
Wed Jul 4 10:48:27 2012, comment #1:

There's more. The situation cannot be fixed by running autogen.sh in target system even if it has required tools (which would not be needed for ./configure && make).

1) aclocal is used to collect old macros from m4/ before libtoolize is used (see 2) to put new macros there
2) as macro files are already present (from tarball) and libtoolize is not forced to overwrite them, old macros remain in m4/

Marko Lindqvist <cazfi>
Project AdministratorIn charge of this item.
Tue Jul 3 18:31:05 2012, original submission:

1. Have libtool 2.4.2 and freeciv svn checkout on computer A
2. ./autogen.sh && make dist
3. Transfer produced tarball to computer B with libtool 2.4
4. ./configure -> fail due to m4 macros being for different libtool version

Marko Lindqvist <cazfi>
Project AdministratorIn charge of this item.

 

(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by cazfi (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Error: not logged in

     

     

    Follow 3 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sun Oct 2 19:59:08 2016cazfiStatusNone=>Duplicate
      Assigned toNone=>cazfi
      Open/ClosedOpen=>Closed
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup