bugBattle for Wesnoth - Bugs: bug #20391, doesn't refresh well graphics when...

Show feedback again

bug #20391: doesn't refresh well graphics when scrolling map

Submitted by:  Gabor Vasmatics <vasmatics>
Submitted on:  Fri 28 Dec 2012 12:02:12 PM UTC  
Category: BugSeverity: 4 - Important
Priority: 5 - NormalItem Group: Graphics
Status: NonePrivacy: Public
Assigned to: NoneOpen/Closed: Open
Release: 1.11.1Operating System: Windows 7

Add a New Comment (Rich MarkupRich Markup):

You are not logged in

Please log in, so followups can be emailed to you.


Sat 26 Sep 2015 07:13:41 PM UTC, comment #3:

Does this still happen? We did have something similar in SDL2 development, but a work-around is currently in place.

Wedge009 <wedge009>
Thu 10 Jan 2013 01:55:25 PM UTC, comment #2:

I checked also the discussion you mentioned. Seems to be very similar.

I'm using the precompiled version. I'll try later on also to compile by myself, and I'll let you know the result.

One of the other laptops (where the game is working) is:
HP Compaq NC6000
Pentium 4 1.8GHz
1G Ram
Ati Mobility Radeon 9600 (with 32 or 64MB RAM, I don't remember)
Windows XP Professional SP3
The drivers are quite old on it, I don't even remember when did I update last time.

The other one is:
Asus K53SV-SX056D
Intel Core i7 i7-2630QM 2GHz
4G Ram
Windows 7 Ultimate x64 SP1
All the drivers and OS updated.

So one is completely different, the other one has different hardware, but nearly same OS.

Gabor Vasmatics <vasmatics>
Sun 06 Jan 2013 12:29:24 AM UTC, comment #1:

See also the forum discussion: http://forums.wesnoth.org/viewtopic.php?f=4&t=37066

One theory was that this had to do with SDL, but that seems weak given that this is happening with 1.11. Still, it wouldn't hurt to check: are you using the premade Windows package, or did you compile from the sources yourself?

What differences exist between this computer and the ones where the game is working (other than the game working on them, of course :) )?

J Tyne <jamit>
Project Member
Fri 28 Dec 2012 12:02:12 PM UTC, original submission:

This problem I faced also on previous versions (both stable and experimental) during summer. Now that a new version came out I though I'll try.
When I scroll, then the whole map becomes a mess, the graphics of the hexes become mixed with each other. This makes the game not playable. You can see the screenshots.
It exists both on full screen and windowed mode and in different resolutions as well. I tried also switching on and off one by one all the graphical options.
The problem existed before and after I refreshed the drivers of the video card and DirectX.
Presently I have this configuration:
Windows 7 Home Premium 64 bit SP1 with all the updates installed
Intel Core2 Duo P8400 2.26GHz
ATI Mobility Radeon HD 3650
Driver Version
Catalyst Version 12.6
2D Driver Version
Direct3D Version
OpenGL Version
DirectX 11

This issue I faced only on this computer, on the other ones I have it was working perfectly fine.

Gabor Vasmatics <vasmatics>


(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):

Attached Files
file #16878:  Clipboard01.jpg added by vasmatics (924kB - image/jpeg)


Depends on the following items: None found

Items that depend on this one: None found


Carbon-Copy List
  • -unavailable- added by wedge009 (Posted a comment)
  • -unavailable- added by jamit (Posted a comment)
  • -unavailable- added by vasmatics (Submitted the item)

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.


    Error: not logged in



    Follow 2 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sun 12 May 2013 04:41:32 PM UTCivanovicSeverity5 - Blocker=>4 - Important
    Fri 28 Dec 2012 12:02:12 PM UTCvasmaticsAttached File-=>Added Clipboard01.jpg, #16878
    Show feedback again

    Back to the top

    Powered by Savane 3.1-cleanup