bugMyPaint - Bugs: bug #20400, [GTK] ValueError: invalid flag...

 
 
Show feedback again

You are not allowed to post comments on this tracker with your current authentification level.

bug #20400: [GTK] ValueError: invalid flag value: 0

Submitted by:  Ryan Schmidt <ryandesign>
Submitted on:  Wed Jan 2 18:42:47 2013  
 
Severity: 3 - NormalPriority: 5 - Normal
Status: InvalidPrivacy: Public
Assigned to: NoneOpen/Closed: Closed
Release: 1.1.0Planned Release: None
Operating System: OS X 10.8

(Jump to the original submission Jump to the original submission)

Sat Jan 5 19:33:22 2013, comment #8:

Ok, then closing this issue.
Thanks for quick and thorough follow-up and your work on MyPaint in macports!

Jon Nordby <jonnor>
Project Administrator
Sat Jan 5 17:34:53 2013, comment #7:

This is the pygobject commit that removed the "invalid flag value" error:

http://git.gnome.org/browse/pygobject/commit/gobject/pygflags.c?h=pygobject-2-28&id=eb0e179bff167303db1c20412f4bc9c8baa94582

This is the ticket that commit purportedly resolved:

https://bugzilla.gnome.org/show_bug.cgi?id=642607

Ryan Schmidt <ryandesign>
Sat Jan 5 17:25:04 2013, comment #6:

I can now confirm that the "invalid flag value" error comes from py-gobject. We were running py-gobject 2.26.0 in MacPorts. Updating to 2.28.6 fixes that error. I have requested py-gobject in MacPorts be updated: https://trac.macports.org/ticket/37538

At this point if I open MyPaint I still get "local variable 'modifiers' referenced before assignment". If I move ~/.mypaint aside and let it be recreated, there is no longer an error.

If I restore ~/.mypaint from my backups from before I started working on the MyPaint 1.1.0 update, and then open MyPaint with py-gobject 2.28.6 installed, MyPaint opens without error.

So I think I can conclude that encountering the "invalid flag value" error with py-gobject 2.26.0 corrupted the settings somehow. So as long as I wait until the update to py-gobject to 2.28.6 is published before I publish the MyPaint 1.1.0 update everything should be fine.

Ryan Schmidt <ryandesign>
Sat Jan 5 12:55:43 2013, comment #5:

Seems like a GTK/pyGTK issue to be, but maybe we can implement a workaround?

Jon Nordby <jonnor>
Project Administrator
Fri Jan 4 15:24:14 2013, comment #4:

Yes, it's pygtk 2.24.0.

Ryan Schmidt <ryandesign>
Fri Jan 4 15:18:51 2013, comment #3:

Also

directly if you could please - I think that's the zero in question.

Andrew Chadwick <achadwick>
Project Administrator
Fri Jan 4 15:17:31 2013, comment #2:

That's two errors, but the second is caused by the first.

For the original one, what version of PyGTK are you running? This should work fine with 2.24.0, and you should be able to do all of

without problems. Let me know if and where any of the >>>s fail :)

Andrew Chadwick <achadwick>
Project Administrator
Wed Jan 2 18:54:47 2013, comment #1:

Now the error has changed to:

Ryan Schmidt <ryandesign>
Wed Jan 2 18:42:47 2013, original submission:

Hello, I'm the maintainer of MyPaint in MacPorts. Having braved the build system and gotten MyPaint 1.1.0 to build and install, it runs, but displays this error every time I start it:

Clicking the "Details..." disclosure triangle produces this text:

Ryan Schmidt <ryandesign>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by jonnor (Posted a comment)
  • -unavailable- added by achadwick (Posted a comment)
  • -unavailable- added by ryandesign (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Error: not logged in

     

     

    Follow 4 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sat Jan 5 19:33:22 2013jonnorStatusNeed Info=>Invalid
      Open/ClosedOpen=>Closed
    Sat Jan 5 12:55:43 2013jonnorSummaryValueError: invalid flag value: 0=>[GTK] ValueError: invalid flag value: 0
    Fri Jan 4 15:18:51 2013achadwickStatusNone=>Need Info
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup