bugMyPaint - Bugs: bug #20410, [Windows] "Precision...

 
 
Show feedback again

You are not allowed to post comments on this tracker with your current authentification level.

bug #20410: [Windows] "Precision mode" on Wacom Intuos tablets causes brush strokes to lag and break

Submitted by:  s12a <s12a>
Submitted on:  Mon 07 Jan 2013 02:03:17 PM UTC  
 
Severity: 3 - NormalPriority: 5 - Normal
Status: DuplicatePrivacy: Public
Assigned to: NoneOpen/Closed: Open
Release: 1.0Planned Release: None
Operating System: Windows 8

(Jump to the original submission Jump to the original submission)

Thu 17 Jul 2014 04:34:30 PM UTC, comment #7:

The breaks pictured look a lot like the dropouts one sees in Linux with the evdev driver for X11: https://github.com/mypaint/mypaint/issues/29
We have a workaround for that now, maybe it helps this bug?

I'd like to know if this is still happening in a recent Windows build of MyPaint using GTK3, specifically one dated after https://github.com/mypaint/mypaint/commit/c8a84143 (13 Jul 2014). That commit is the one that makes the evdev dropouts disappear, anyway.

This may involve waiting for someone to make a Windows 1.1.1-alpha build, and the place to watch for that is http://opensourcepack.blogspot.co.uk/search/label/mypaint I think. In the meantime though, testing on a 1.1.0+git release could be useful too.

---------------------------

This bug tracker will shortly be moving to github. As part of this
process, we're reviewing old bug reports on gna.org and moving
them over. Please report new bugs at the new locations:

https://github.com/mypaint/mypaint/issues for the mypaint app, or
https://github.com/mypaint/libmypaint/issues for its brushlib

Andrew Chadwick <achadwick>
Project Administrator
Mon 07 Jan 2013 06:36:14 PM UTC, comment #6:

An even easier way to reproduce the issue highlighted in comment #5

- Have a MyPaint floating tool window on the canvas area (for example the Layers window)
- Start drawing on the canvas
- Without lifting the pen, keep drawing through/below the floating tool window. Go through it several times
- When you're done, move the floating tool window around

You will see the portion of the brush stroke drawn below the floating tool Window will show many tiny, individually undoable segments. Again, this doesn't seem to affect consecutive brush strokes like what I reported originally.

See attached images.

(file #16906, file #16907)

s12a <s12a>
Mon 07 Jan 2013 06:14:18 PM UTC, comment #5:

I found a simpler way to "sort of" reproduce this issue:

- Draw a relatively quick brush stroke in a downward motion
- While drawing, press the X key to activate the color history popup window
- Keep drawing in a downward motion until the popup window disappears

You will see that the line portion drawn below the color history popup window will be made of tiny, individually undoable segments.

Not exactly the same problem as it only affects a brush stroke portion, but it seems related to the issue I originally reported and perhaps to bug #19948 too

(file #16904, file #16905)

s12a <s12a>
Mon 07 Jan 2013 05:49:20 PM UTC, comment #4:

That you have tiny undoable segments sounds just very much like those frequent device changes, where GTK+ is reporting both mouse an tablet events when it should suppress mouse events.

I have no proof for that, of course, but it's good to have the two bugreports linked.

Martin Renold <martinxyz>
Project Administrator
Mon 07 Jan 2013 05:41:14 PM UTC, comment #3:

I asked on IRC first, I was suggested to report this as a new bug as it seems it is a slightly different issue (though maybe related?) than what was reported on #19948.

s12a <s12a>
Mon 07 Jan 2013 05:37:26 PM UTC, comment #2:

I'm pretty sure this is a duplicate of bug #19948

Martin Renold <martinxyz>
Project Administrator
Mon 07 Jan 2013 04:07:39 PM UTC, comment #1:

Additional info for Linux users: the "precision mode" on Windows drivers is a function which temporarily remaps on the tablet active area a smaller portion of the screen (around the on-screen pointer), enhancing precision.

Since one of the latest windows Wacom driver versions, when this mode gets toggled on, a darkened mask covering unmapped display areas gets overlaid on screen. This is probably what is causing problems on MyPaint after the first brush stroke.

(file #16903)

s12a <s12a>
Mon 07 Jan 2013 02:03:17 PM UTC, original submission:

This issue is 100% reproducible on Windows 7 and 8 with the latest Wacom drivers (6.3.4-3 as of writing) and MyPaint 1.0, official release.

When enabling the "precision mode" on Wacom Intuos tablets, immediately after the first stroke in such mode, all subsequent brush strokes in MyPaint 1.0 acquire a severe lag (strokes appearing a couple seconds after the actual pen movement), in addition of getting broken into multiple segments (hundreds). When using the program's undo function, such segments get individually removed. They are treated as individual strokes.
Furthermore, the program's pan function becomes severely lagged as well.

The only ways to restore the tablet's normal mode of operation with this program is either to:

- Move the pointer away from the MyPaint window (does not always work)
- Briefly using the stylus' eraser (does not always work)
- Select a different brush tool (almost always work)
- Close and reopen the program (always works)

This bug might be in part related to #19948
https://gna.org/bugs/?

I've attached a couple of example of brush strokes affected by this bug.

s12a <s12a>

 

Attached Files
file #16906:  bug_02_01.png added by s12a (36kB - image/png)
file #16907:  bug_02_02.png added by s12a (50kB - image/png)
file #16904:  bug_01.png added by s12a (5kB - image/png)
file #16905:  bug_02.png added by s12a (5kB - image/png)
file #16903:  prec.jpg added by s12a (170kB - image/jpeg)
file #16901:  precbroken.png added by s12a (24kB - image/png)
file #16902:  precbroken2.png added by s12a (36kB - image/png)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by achadwick (Posted a comment)
  • -unavailable- added by martinxyz (Posted a comment)
  • -unavailable- added by s12a (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 8 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Mon 07 Jan 2013 06:36:14 PM UTCs12aAttached File-=>Added bug_02_02.png, #16907
    Mon 07 Jan 2013 06:36:13 PM UTCs12aAttached File-=>Added bug_02_01.png, #16906
    Mon 07 Jan 2013 06:14:18 PM UTCs12aAttached File-=>Added bug_01.png, #16904
      Attached File-=>Added bug_02.png, #16905
    Mon 07 Jan 2013 05:37:26 PM UTCmartinxyzStatusNone=>Duplicate
    Mon 07 Jan 2013 04:07:39 PM UTCs12aAttached File-=>Added prec.jpg, #16903
    Mon 07 Jan 2013 02:03:17 PM UTCs12aAttached File-=>Added precbroken.png, #16901
      Attached File-=>Added precbroken2.png, #16902
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup