bugFreeciv - Bugs: bug #20499, ruleset datafile appears...

 
 
Show feedback again

bug #20499: ruleset datafile appears incompatible

Submitted by:  David Lowe <doctorjlowe>
Submitted on:  Mon 11 Feb 2013 09:16:52 PM UTC  
 
Category: rulesetsSeverity: 5 - Blocker
Priority: 5 - NormalStatus: Invalid
Assigned to: NoneOpen/Closed: Closed
Release: r22326Operating System: GNU/Linux
Planned Release: 

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Tue 12 Feb 2013 04:43:34 AM UTC, comment #2:

Whoops, it appears i had forgotten to 'make install' and then ran the old binary [2.4-beta1]. Sorry for the noise.

David Lowe <doctorjlowe>
Mon 11 Feb 2013 09:41:58 PM UTC, comment #1:

Is that S2_4 or TRUNK?

> "supported options: +Freeciv-2.4-ruleset"


This looks like your binary is S2_4...

> "datafile options: +Freeciv-ruleset-Devel-2012.Feb.28"


...and this is TRUNK datafile.

And then

> ""usr/local/share/freeciv/experimental/nations.ruleset": ruleset datafile appears incompatible:"


experimental has no nations.ruleset of its own (it should fallback to default/nations.ruleset) in S2_4, so this too seems like TRUNK.

You seem to be running installed freeciv ('make install'), or the very problem is that datafiles currently in install hierarchy are used, so this could be caused by installing S2_4 over TRUNK installation. As S2_4 has no experimental/nations.ruleset, it doesn't get overwritten. When you then run that S2_4 freeciv, it finds the TRUNK experimental/nations.ruleset instead of fallbacking to default/nations.ruleset

Marko Lindqvist <cazfi>
Project Administrator
Mon 11 Feb 2013 09:16:52 PM UTC, original submission:

This is on Debian Squeeze PPC. After 'svn up' and a fresh build, i attempted to start a new game with the experimental ruleset. The GUI immediately gave me a stack of popup requests, including [in no particular order]:

"Capability problem"
"supported options: +Freeciv-2.4-ruleset"
"datafile options: +Freeciv-ruleset-Devel-2012.Feb.28"
""usr/local/share/freeciv/experimental/nations.ruleset": ruleset datafile appears incompatible:"

Terminal output looks like this:

$ freeciv-gtk2
1: Invalid NULL default string for option default_tileset_name.
1: in option_str_set() [options.c::752]: assertion '((void *)0) != str' failed.
1: Please report this message at http://gna.org/projects/freeciv/
0: No usable default tileset found, aborting!

The default ruleset works just fine.

David Lowe <doctorjlowe>

 

(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by pepeto (Updated the item)
  • -unavailable- added by cazfi (Posted a comment)
  • -unavailable- added by doctorjlowe (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 2 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sat 16 Feb 2013 11:34:15 PM UTCpepetoStatusNone=>Invalid
      Open/ClosedOpen=>Closed
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup