bugMyPaint - Bugs: bug #20583, Low panning performance after the...

 
 
Show feedback again

You are not allowed to post comments on this tracker with your current authentification level.

bug #20583: Low panning performance after the 'preview' addition

Submitted by:  David REVOY <deevad>
Submitted on:  Mon Mar 4 13:17:20 2013  
 
Severity: 4 - ImportantPriority: 5 - Normal
Status: FixedPrivacy: Public
Assigned to: Andrew Chadwick <achadwick>Open/Closed: Closed
Release: 1.1+GitPlanned Release: None
Operating System: Linux

Mon Jun 23 21:51:25 2014, comment #5:

[This is a canned response, please forgive the broken formatting: it's one of the many things Gna! unfortunately does not do well.]

This bug tracker will shortly be moving to Github. As part of this process, we are reviewing old bug reports on gna.org.

This bug was marked as Fixed long ago, but was still classified as Open. Github does not distinguish between Fixed+Open and Fixed+Closed in the
way we once did here, so this bug is now being marked Closed, and will not be migrated into the github issues tracker.

If you believe that this bug still affects the most recent git master of MyPaint (and thus the next release), please feel free to open a new
issue on Github about it. Our new issue trackers are:

https://github.com/mypaint/mypaint/issues
https://github.com/mypaint/libmypaint/issues

Andrew Chadwick <achadwick>
Project AdministratorIn charge of this item.
Wed Mar 6 09:29:54 2013, comment #4:

Perfect ! Its smooth again here to pan on canvas.
Grabbing the preview square make a lower "frame per second" motion, but this is not a problem as the feedback movement is perfect, and motion smooth and real-time compare to user's decisions. Thanks for the superfast fix.

David REVOY <deevad>
Project Member
Wed Mar 6 09:02:18 2013, comment #3:

Fix committed: https://gitorious.org/mypaint/mypaint/commit/2ebc1458fd62f47ddc723f5579883735df37cb98

David: could you try this out please and let me know if panning the main view with the preview subwindow feels less slow? And the same when grabbing the preview rectangle.

Andrew Chadwick <achadwick>
Project AdministratorIn charge of this item.
Wed Mar 6 04:08:54 2013, comment #2:

Workaround: turn the preview window off, and close MyPaint before working on really huge files.

Andrew Chadwick <achadwick>
Project AdministratorIn charge of this item.
Wed Mar 6 04:07:39 2013, comment #1:

Confirmed for huge docs, zoomed out in the main area. If the preview has been on, then even closing it doesn't help. Strong red line down the centre of the profiling graph...

Need to be smarter about calling notify_view_changed() in intensive drags, or it needs to be smarter, or we need tiledsurface to cache extents (again ☺)

Andrew Chadwick <achadwick>
Project AdministratorIn charge of this item.
Mon Mar 4 13:17:20 2013, original submission:

About panning the viewport ( space / mouse middle click or via panning tool ) it get really slow. I saw it after the 'preview' new feature.
Btw, grabbing the cyan rectangle inside the 'preview' widget pan more smoothly.

David REVOY <deevad>
Project Member

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by achadwick (Posted a comment)
  • -unavailable- added by deevad (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Error: not logged in

     

     

    Follow 6 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Mon Jun 23 21:51:25 2014achadwickOpen/ClosedOpen=>Closed
    Wed Mar 6 10:22:50 2013achadwickStatusReady For Test=>Fixed
    Wed Mar 6 09:02:18 2013achadwickStatusConfirmed=>Ready For Test
    Wed Mar 6 04:07:39 2013achadwickSeverity3 - Normal=>4 - Important
      StatusNone=>Confirmed
      Assigned toNone=>achadwick
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup