bugFreeciv - Bugs: bug #20965, Unable to load scenarios,...

 
 
Show feedback again

bug #20965: Unable to load scenarios, savegames too old

Submitted by:  Andreas Rosdal <andreasr>
Submitted on:  Sat 13 Jul 2013 08:25:11 AM UTC  
 
Category: generalSeverity: 4 - Important
Priority: 5 - NormalStatus: Duplicate
Assigned to: Marko Lindqvist <cazfi>Open/Closed: Closed
Release: Operating System: None
Planned Release: 2.6.0

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sun 08 Sep 2013 05:33:47 PM UTC, comment #2:

While there's still more scenarios to update to 2.5 format in patch #3864, all scenarios that had format older than 2.0 have now been updated, i.e., all scenarios should now have format version currently supported.

Marko Lindqvist <cazfi>
Project AdministratorIn charge of this item.
Sat 13 Jul 2013 08:32:16 AM UTC, comment #1:

Sorry, i didn't realize that our scenario formats are that old when dropping support for loading ancient saves from TRUNK version.

As per patch #3864, plan is to update scenarios to 2.5 format once the format is frozen. I also hope to make that update part of normal release cycle so that scenarios are updated again once 2.6 format freezes.

Marko Lindqvist <cazfi>
Project AdministratorIn charge of this item.
Sat 13 Jul 2013 08:25:11 AM UTC, original submission:

I'm unable to load most of the scenarios which are distributed with Freeciv trunk. I get the error message:
"Saved game is too old, at least version 2.0.0 required."

Looking at for example europe-200x100-v2.sav, I see that version=11105 while the savegame loading code requires at least 20000. So do the savegames have to be updated, or is this a bug in the savegame loading code?

Andreas Rosdal <andreasr>
Project Member

 

(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by cazfi (Posted a comment)
  • -unavailable- added by andreasr (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 4 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sun 08 Sep 2013 05:33:47 PM UTCcazfiStatusNone=>Duplicate
      Assigned toNone=>cazfi
      Open/ClosedOpen=>Closed
      Planned Release=>2.6.0
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup