bugFreeciv - Bugs: bug #20999, Info label just black box in...

 
 
Show feedback again

bug #20999: Info label just black box in Windows Gtk3 builds (Gtk bug?)

Submitted by:  Marko Lindqvist <cazfi>
Submitted on:  Wed Jul 31 16:43:25 2013  
 
Category: client-gtk-3.0Severity: 4 - Important
Priority: 5 - NormalStatus: Duplicate
Assigned to: Marko Lindqvist <cazfi>Open/Closed: Closed
Release: Operating System: Microsoft Windows
Planned Release: 2.5.0,2.6.0Contains string changes: None

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Thu Feb 5 04:55:51 2015, comment #8:

bug #23246, task #7870 :
Windows Installer build Makefile needs to be updated to match newer bundle -> we don't have build-time option to select which bundle to use but it's dictated by the source (Makefile content).

So this ticket is going to resolve itself if bug #23246 gets committed.

Marko Lindqvist <cazfi>
Project AdministratorIn charge of this item.
Fri Jan 30 05:09:45 2015, comment #7:

As 3.6.4 is anyway not sufficient for freeciv-2.6 builds, our gnuwin environments have to use those newer gtk+ versions that do not have this problem (unless we use different gnuwin environments depending on freeciv branch being built).

2.5.0-beta2 was already built with gtk+ 3.10.4 (by cproc)
http://download.gna.org/freeciv/packages/windows/testing/cazfi/2.5.0-beta2+-r27850/ were still built with older gnuwin environment containing gtk+ 3.6.4 (by me)

Marko Lindqvist <cazfi>
Project AdministratorIn charge of this item.
Sat Sep 20 16:55:41 2014, comment #6:

> There's now multiple versions of windows gtk+3 builds available
> at http://win32builder.gnome.org/ [...]
> 3.6.4 is still listed as the current officially supported one,
> though.

And this mailing list post indicates that that's a deliberate policy rather than an oversight, and that we might be letting ourselves in for trouble with the newer bundles.

3.6.4 is clearly unusable for us, though, so I think we should make the next experimental Gtk3 builds with the latest bundle available on win32builder.

Jacob Nevins <jtn>
Project Administrator
Sat Sep 20 16:26:15 2014, comment #5:

I've confirmed the fix with cazfi's (non-crosser, I assume) 2.5.0-beta0 test builds of 3.8.2 and 3.10.4 (and reproduced it with the 3.6.4 that is there).

Jacob Nevins <jtn>
Project Administrator
Tue Jun 3 17:39:57 2014, comment #4:

There's now multiple versions of windows gtk+3 builds available at http://win32builder.gnome.org/ I expect each of them having different kinds of problems for us to choose from...
3.6.4 is still listed as the current officially supported one, though.

Marko Lindqvist <cazfi>
Project AdministratorIn charge of this item.
Sat Nov 30 12:36:41 2013, comment #3:

Marking as blocker for 2.5.0 since this blocks Gtk3 client as default. (Of course if there's any easy fix within Freeciv we should consider backporting it to S2_4 too.)

Jacob Nevins <jtn>
Project Administrator
Sun Nov 17 12:52:20 2013, comment #2:

I get the same in cproc's build referenced in task #7681.

It happens to the middle-click popup on the map view, and the left-click popup on the left-hand bar of the main window; but the left-click popups in the city dialog are fine for me.

Jacob Nevins <jtn>
Project Administrator
Sun Aug 4 13:11:14 2013, comment #1:

This seems like bug in gtk. At least it works again with crosser development version that contains newer version of gtk (3.8.2 instead of 3.6.4)

Marko Lindqvist <cazfi>
Project AdministratorIn charge of this item.
Wed Jul 31 16:43:25 2013, original submission:

Popup opened by middle-clicking a tile is just black box (maybe black text on black background) on crosser-based build.

Marko Lindqvist <cazfi>
Project AdministratorIn charge of this item.

 

(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Digest:
   task dependencies.

 

Carbon-Copy List
  • -unavailable- added by jtn (Posted a comment)
  • -unavailable- added by cazfi (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Error: not logged in

     

     

    Follow 9 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Thu Feb 19 16:47:29 2015cazfiStatusNone=>Duplicate
      Assigned toNone=>cazfi
      Open/ClosedOpen=>Closed
    Sun Sep 14 10:46:46 2014jtnSummaryInfo label just black box in Windows Gtk3 builds=>Info label just black box in Windows Gtk3 builds (Gtk bug?)
    Fri Jul 4 09:27:05 2014jtnSeverity5 - Blocker=>4 - Important
    Sat Nov 30 12:53:13 2013jtnSummaryInfo label just black box in crosser-based build=>Info label just black box in Windows Gtk3 builds
    Sat Nov 30 12:36:41 2013jtnSeverity4 - Important=>5 - Blocker
      Planned Release=>2.5.0,2.6.0
    Sun Nov 17 12:52:20 2013jtnSeverity3 - Normal=>4 - Important
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup