bugFreeciv - Bugs: bug #21138, Roads not present loading 2.4...

 
 
Show feedback again

bug #21138: Roads not present loading 2.4 savegame into trunk

Submitted by:  Jacob Nevins <jtn>
Submitted on:  Sun 15 Sep 2013 01:07:42 PM UTC  
 
Category: generalSeverity: 3 - Normal
Priority: 5 - NormalStatus: Duplicate
Assigned to: Marko Lindqvist <cazfi>Open/Closed: Closed
Release: trunk r23413Operating System: GNU/Linux
Planned Release: 2.6.0

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Sun 29 Sep 2013 07:11:26 PM UTC, comment #7:

Seems to be caused by bug #19836.

Marko Lindqvist <cazfi>
Project AdministratorIn charge of this item.
Sun 29 Sep 2013 06:50:28 PM UTC, comment #6:

Remaining error message is about units building Railroad doing illegal activity. This seems to be because there's no roads anywhere (especially not where engineers are trying to upgrade them to railroads)

Marko Lindqvist <cazfi>
Project AdministratorIn charge of this item.
Sun 29 Sep 2013 06:28:41 PM UTC, SVN revision 23511:

Fixed loading of old savegames where extra owner information is not set for player
maps.

Originally reported by Jacob Nevins as part of bug #21138

See bug #21164

(Browse SVN revision 23511)

Marko Lindqvist <cazfi>
Project AdministratorIn charge of this item.
Sun 15 Sep 2013 01:58:20 PM UTC, comment #4:

>> during S2_4 development
> So it's not really 2.4 format despite the format version
> claiming so?

This is a doubt I had. But the file was saved on 2012-08-17, and I expect it would have been saved with the current S2_4 svn version of Freeciv at the time, which was post beta1 and hence well after the datafile format freeze.

For comparison, it loads into 2.4.0 apparently fine.

Jacob Nevins <jtn>
Project Administrator
Sun 15 Sep 2013 01:26:28 PM UTC, comment #3:

Bah, I mean bug #21126.

Marko Lindqvist <cazfi>
Project AdministratorIn charge of this item.
Sun 15 Sep 2013 01:25:37 PM UTC, comment #2:

btw. The plrcolor error messages seem similar to ones in bug #21136. Is that too because of unsupported format?

Marko Lindqvist <cazfi>
Project AdministratorIn charge of this item.
Sun 15 Sep 2013 01:23:47 PM UTC, comment #1:

> during S2_4 development


So it's not really 2.4 format despite the format version claiming so? That's known problem with current compatibility model. We really support loading from released formats only.

Marko Lindqvist <cazfi>
Project AdministratorIn charge of this item.
Sun 15 Sep 2013 01:07:42 PM UTC, original submission:

Loading file #17386 (a savegame created during S2_4 development) into current trunk (r23413) gives many errors. If one proceeds to start the game, the server crashes.

I haven't investigated what's going on at all, but it's been unclean for a while (I use this as an example of a game in progress when testing things). There might need to be multiple tickets spawned from this one.

Just loading into a server we get:

Loading in the client (which does additional server commands) gives additionally:

Jacob Nevins <jtn>
Project Administrator

 

(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by cazfi (Posted a comment)
  • -unavailable- added by jtn (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 6 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sun 29 Sep 2013 07:11:26 PM UTCcazfiStatusIn Progress=>Duplicate
      Assigned toNone=>cazfi
      Open/ClosedOpen=>Closed
    Sun 29 Sep 2013 06:50:27 PM UTCcazfiCategoryNone=>general
      StatusNone=>In Progress
      SummaryMany error messages / crash loading 2.4 savegame into trunk=>Roads not present loading 2.4 savegame into trunk
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup