bugBattle for Wesnoth - Bugs: bug #21306, Issue on [filter_vision] tag on...

 
 
Show feedback again

bug #21306: Issue on [filter_vision] tag on 1.11.7

Submitted by:  None
Submitted on:  Tue 26 Nov 2013 04:44:44 PM UTC  
 
Category: BugSeverity: 3 - Normal
Priority: 5 - NormalItem Group: WML
Status: InvalidPrivacy: Public
Assigned to: Matthias Schoeck <mattsc>Originator Email: -unavailable-
Open/Closed: ClosedRelease: BfW 1.11.7
Operating System: Mac OSX 10.5.8

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Mon 24 Feb 2014 01:13:49 AM UTC, comment #3:

mattsc said this on IRC:

> As far as I can tell, the reported bugs were not bugs and what I fixed was unrelated.
> The second poster might be referring to the same bug I fixed, but I got no confirmation of that when I asked for more information.

Ignacio R. Morelle <shadowmaster>
Project Administrator
Sat 18 Jan 2014 06:04:17 PM UTC, comment #2:

I looked into this after I found a possibly related/similar bug with a wose moving onto forest terrain (where it is invisible to enemies) under fog causing [filter_vision] in SUFs to give a false positive result. It turns out that this was caused by a bug that apparently has been around almost since the introduction of [filter_vision] and that might be the cause of some of the strange behavior with [filter_vision] and sighted events that has been observed over the years (just a guess, not sure about that). This bug has been fixed in trunk and will be fixed in 1.11.9.

Having said that, the two issues reported here might actually be two separate things:

SkyOne: looking at your scenario code, you are using viewing_side= which has been deprecated for quite some time and was removed in 1.11.5. Could you replace that by side= and see if that fixes things?

Second anonymous poster: it is possible that your problem might be caused by the bug described above, but since you don't provide details, I can't be sure. Are you able to compile trunk and test whether the problem has disappeared? Alternatively, can you post a test case that I could check out?

Matthias Schoeck <mattsc>
Project MemberIn charge of this item.
Sat 30 Nov 2013 11:32:37 PM UTC, comment #1:

I'm not SkyOne, but I can confirm that [filter_vision] behaves strangely on 1.11.7 Linux as well. I had a case where the key "visible=yes" did not work, but setting it to "visible=no", then wrapping [filter_vision] in [not], did work.

Anonymous
Tue 26 Nov 2013 04:44:44 PM UTC, original submission:

Hello,

It seems that there is an issue on the [filter_vision] tag of BfW 1.11.7. I am actually using a lot of it on three own add-ons, and some of them do not trigger even they worked fine on BfW 1.11.2.

I don't see any differences between worked one and unworked one, so unable to attach the obvious evidences at this moment. But several [filter_vision] tags as sighted,moveto and moveto [event] have been installed on the scenario that I attached, and only one of them triggers as well on 1.11.7. Although I changed them to work as well on 1.11.7, I put some comments on it to tell which one triggered and which one did not.

I would appreciate if someone takes a look at and investigates it.

Thanks for working hard.
Best regard
SkyOne

Anonymous

 

(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files
file #19388:  13_Orcish_Wizard.cfg added by None (27kB - application/octet-stream)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by shadowmaster (Posted a comment)
  • -unavailable- added by mattsc (Posted a comment)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 5 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Mon 24 Feb 2014 01:13:49 AM UTCshadowmasterStatusReady For Test=>Invalid
      Open/ClosedOpen=>Closed
    Sat 18 Jan 2014 06:04:17 PM UTCmattscStatusNone=>Ready For Test
      Assigned toNone=>mattsc
    Tue 26 Nov 2013 04:44:44 PM UTCNoneAttached File-=>Added 13_Orcish_Wizard.cfg, #19388
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup