bugrelax - Bugs: bug #21520, Failure of the structure.write_pdb...

 
 
Show feedback again

bug #21520: Failure of the structure.write_pdb user function if too many models, hence atoms, are present.

Submitted by:  Edward d Auvergne <bugman>
Submitted on:  Mon 20 Jan 2014 04:11:38 PM UTC  
 
Category: NoneSpecific analysis category: None
Priority: 5 - NormalSeverity: 3 - Normal
Status: DuplicateAssigned to: Edward d Auvergne <bugman>
Originator Name: Open/Closed: Closed
Release: 3.1.3Operating System: All systems

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Tue 21 Jan 2014 09:35:16 AM UTC, SVN revision 22038:

Merged revisions 22034 via svnmerge from
svn+ssh://bugman@svn.gna.org/svn/relax/trunk

........
r22034 | bugman | 2014-01-21 10:30:24 +0100 (Tue, 21 Jan 2014) | 10 lines

Fix for bug #21522 (https://gna.org/bugs/?21522) and bug #21520 (https://gna.org/bugs/?21520).

These bugs are the structure.write_pdb user function creating an incorrect MASTER record and the
failure of the structure.write_pdb user function when creating the MASTER record due to too many
ATOM and HETATM records being present.

The counts for the ATOM, HETATM, and TER records are now only for a single model, rather than being
the sum for all models together.
........

(Browse SVN revision 22038)

Edward d Auvergne <bugman>
Project AdministratorIn charge of this item.
Tue 21 Jan 2014 09:31:30 AM UTC, SVN revision 22035:

Merged revisions 22031 via svnmerge from
svn+ssh://bugman@svn.gna.org/svn/relax/trunk

........
r22031 | bugman | 2014-01-21 10:15:22 +0100 (Tue, 21 Jan 2014) | 11 lines

Created the Structure.test_bug_21522_master_record_atom_count system test.

This is designed to catch bug #21522 (https://gna.org/bugs/?21522), the structure.write_pdb user
function creating an incorrect MASTER record. This hence also catches bug #21520
(https://gna.org/bugs/?21520), the failure of the structure.write_pdb user function when creating
the MASTER record due to too many ATOM and HETATM records being present.

The test simply creates to structural models, adds one atom, and writes out a PDB file, checking its
contents.
........

(Browse SVN revision 22035)

Edward d Auvergne <bugman>
Project AdministratorIn charge of this item.
Tue 21 Jan 2014 09:30:24 AM UTC, SVN revision 22034:

Fix for bug #21522 (https://gna.org/bugs/?21522) and bug #21520 (https://gna.org/bugs/?21520).

These bugs are the structure.write_pdb user function creating an incorrect MASTER record and the
failure of the structure.write_pdb user function when creating the MASTER record due to too many
ATOM and HETATM records being present.

The counts for the ATOM, HETATM, and TER records are now only for a single model, rather than being
the sum for all models together.

(Browse SVN revision 22034)

Edward d Auvergne <bugman>
Project AdministratorIn charge of this item.
Tue 21 Jan 2014 09:15:23 AM UTC, SVN revision 22031:

Created the Structure.test_bug_21522_master_record_atom_count system test.

This is designed to catch bug #21522 (https://gna.org/bugs/?21522), the structure.write_pdb user
function creating an incorrect MASTER record. This hence also catches bug #21520
(https://gna.org/bugs/?21520), the failure of the structure.write_pdb user function when creating
the MASTER record due to too many ATOM and HETATM records being present.

The test simply creates to structural models, adds one atom, and writes out a PDB file, checking its
contents.

(Browse SVN revision 22031)

Edward d Auvergne <bugman>
Project AdministratorIn charge of this item.
Tue 21 Jan 2014 09:05:33 AM UTC, comment #1:

This problem is caused by bug #21522 (https://gna.org/bugs/index.php?21522).

Edward d Auvergne <bugman>
Project AdministratorIn charge of this item.
Mon 20 Jan 2014 04:11:38 PM UTC, original submission:

If too many atoms are present, the MASTER record creation fails with the error about the MASTER record being too long. The message with the debugging flag turned on is:

Traceback (most recent call last):
File "/data/relax/branches/double_rotor/prompt/interpreter.py", line 341, in exec_script
runpy.run_module(module, globals)
File "/usr/lib64/python2.7/runpy.py", line 180, in run_module
fname, loader, pkg_name)
File "/usr/lib64/python2.7/runpy.py", line 72, in _run_code
exec code in run_globals
File "/data/relax/branches/double_rotor/test_suite/shared_data/frame_order/cam/double_rotor/generate_distribution.py", line 46, in <module>
generate.run()
File "../generate_base.py", line 77, in run
self._create_distribution()
File "../generate_base.py", line 229, in _create_distribution
self.interpreter.structure.write_pdb('distribution.pdb', compress_type=2, force=True)
File "/data/relax/branches/double_rotor/prompt/uf_objects.py", line 221, in _call_
self._backend(*new_args, **uf_kargs)
File "/data/relax/branches/double_rotor/pipe_control/structure/main.py", line 1212, in write_pdb
cdp.structure.write_pdb(file, model_num=model_num)
File "/data/relax/branches/double_rotor/lib/structure/internal/object.py", line 2709, in write_pdb
pdb_write.master(file, num_het=len(het_data_coll), num_coord=num_atom+num_hetatm, num_ter=num_ter, num_conect=num_conect)
File "/data/relax/branches/double_rotor/lib/structure/pdb_write.py", line 1330, in master
_record_validate(text)
File "/data/relax/branches/double_rotor/lib/structure/pdb_write.py", line 85, in _record_validate
raise RelaxError("The PDB record '%s' is too long." % record)
RelaxError: RelaxError: The PDB record 'MASTER 0 0 2 0 0 0 0 0135000 1000 0 0 ' is too long.

Edward d Auvergne <bugman>
Project AdministratorIn charge of this item.

 

(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by bugman (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 2 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Tue 21 Jan 2014 09:05:33 AM UTCbugmanStatusNone=>Duplicate
      Open/ClosedOpen=>Closed
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup