bugBattle for Wesnoth - Bugs: bug #21647, Elipses randomly missing

 
 
Show feedback again

bug #21647: Elipses randomly missing

Submitted by:  None
Submitted on:  Thu Feb 13 16:01:40 2014  
 
Category: BugSeverity: 2 - Minor
Priority: 5 - NormalItem Group: Graphics
Status: FixedPrivacy: Public
Assigned to: Ignacio R. Morelle <shadowmaster>Originator Email: -unavailable-
Open/Closed: ClosedRelease: 1.11.9
Operating System: OSX

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Mon Jul 13 21:30:48 2015, comment #7:

Fixed in 1.12.3/1.12.4 (commit), I just didn't find the original bug report in time because I wasn't expecting 'ellipse' to be misspelled in it.

Ignacio R. Morelle <shadowmaster>
Project AdministratorIn charge of this item.
Fri Apr 11 06:25:17 2014, comment #6:

I find that one way to reproduce this consistently is to join any game with some moves in it as an observer, using "quick replays". It looks like every side that is not the side whose turn it finally is when you catch up will have all of their units missing health bars, orbs, and elipses.

Chris Beck <involution>
Project Member
Sun Feb 23 02:33:18 2014, comment #5:

This is probably not very helpful since I am still unsure about how to reproduce it in a more deterministic fashion, but I have seen this happen with units in fairly vanilla replays I have produced in 1.11.9+dev/1.11.10 (from unmodified mainline campaigns) while testing other things.

Ignacio R. Morelle <shadowmaster>
Project AdministratorIn charge of this item.
Sun Feb 23 02:30:51 2014, comment #4:

I've tried reproducing the exact combination of unit, facing, and terrain that I see in the screenshot, but I was not able to reproduce the issue. Marking this as "Need Info", since we will probably need a semi-reliable way to reproduce this before the problem can be diagnosed.

J Tyne <jamit>
Project Member
Sun Feb 16 17:12:00 2014, comment #3:

It doesn't look like it's just an ellipse problem. Those units are also missing their bars and orbs. (I'm not the original poster.)

Anonymous
Fri Feb 14 05:34:35 2014, comment #2:

Do those units, by any chance, have a custom ellipse set in their attributes? The changes to its semantics in version 1.11.6 may result in issues like that with old saved games or custom unit types.

(You may check their attributes by using :debug :inspect, or saving a game and looking at the uncompressed text contents. Alternatively, you may upload a saved game here, as long as it doesn't require any add-ons.)

Ignacio R. Morelle <shadowmaster>
Project AdministratorIn charge of this item.
Fri Feb 14 02:02:15 2014, comment #1:

In the image, the two units without ellipses are the two units on elven villages. Is that always the case? (If so, I wouldn't call it "random".)

J Tyne <jamit>
Project Member
Thu Feb 13 16:01:40 2014, original submission:

As the subject says, there are times in the development version where for an unknown reason the elipses of some units on a side are not drawn (see attached jpeg for an example).

I have seen this behavior in both single player and multiplayer.

Anonymous

 

(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files
file #20033:  bug.jpg added by None (145kB - image/jpeg - This is an example.)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by involution (Posted a comment)
  • -unavailable- added by shadowmaster (Posted a comment)
  • -unavailable- added by jamit (Posted a comment)
  • -unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Error: not logged in

     

     

    Follow 6 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Mon Jul 13 21:30:48 2015shadowmasterStatusNeed Info=>Fixed
      Assigned toNone=>shadowmaster
      Open/ClosedOpen=>Closed
    Sun Feb 23 02:30:51 2014jamitStatusNone=>Need Info
    Fri Feb 14 02:02:15 2014jamitItem Group None of the others=>Graphics
    Thu Feb 13 16:01:40 2014NoneAttached File-=>Added bug.jpg, #20033
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup