bugMyPaint - Bugs: bug #21864, [Windows, Old version] MyPaint's...

 
 
Show feedback again

You are not allowed to post comments on this tracker with your current authentification level.

bug #21864: [Windows, Old version] MyPaint's Pen Pressure doesn't work/Pointer not detected? (Screencaps included)

Submitted by:  Alexandria <atsusakaneytza>
Submitted on:  Wed 26 Mar 2014 09:43:15 AM UTC  
 
Severity: 2 - MinorPriority: 3 - Low
Status: NonePrivacy: Public
Assigned to: Bakhtiar <tumagonx>Open/Closed: Open
Release: 1.0Planned Release: None
Operating System: Windows 8

(Jump to the original submission Jump to the original submission)

Fri 11 Jul 2014 10:45:17 PM UTC, comment #7:

Just been pointed here - nice catch in the followups, thanks all.

Maybe we should make it a FAQ item? Reopening to remind myself to make it into a docs issue on the new tracker more than anything.

---------------------------

This bug tracker will shortly be moving to github. As part of this
process, we're reviewing old bug reports on gna.org and moving
them over. Please report new bugs at the new locations:

https://github.com/mypaint/mypaint/issues for the mypaint app, or
https://github.com/mypaint/libmypaint/issues for its brushlib

Andrew Chadwick <achadwick>
Project Administrator
Fri 28 Mar 2014 01:40:58 AM UTC, comment #6:

So, the old WinTab32.dll files are about 2 years old, so I replaced them with the driver files from the UC Logic driver package and after a restart, MyPaint's pen pressure works! Thank you so much!

Alexandria <atsusakaneytza>
Thu 27 Mar 2014 10:02:30 PM UTC, comment #5:

In that case could you check what version is your C:\Windows\syswow64\WinTab32.dll file

just in case... cause sometime the driver installer a bit flaky at updating

Bakhtiar <tumagonx>
Project AdministratorIn charge of this item.
Thu 27 Mar 2014 04:06:11 PM UTC, comment #4:

Yes, both tablets are UC Logic tablets. I use the latest drivers for both tablets already, and they work fine in other drawing software. I'll be sure to report it as you say.

Alexandria <atsusakaneytza>
Thu 27 Mar 2014 01:24:49 AM UTC, comment #3:

Does Monoprice 4x3 a UC Logic tablet?
Mine mousepen 8x6 (UC logic) has the same issue as you describe, and can be fixed using their latest driver.

It's true that mypaint 1.1 behave differently than others regarding driver support but if there is GIMP 3.x I'm sure it'll behave the same like mypaint 1.1. The issue is not from mypaint but rather GTK (a 3rd party component). You may want to submit a separate bugreport for this at bugzilla.gnome.org

Interesting about administrative privilege issue, I will test it but no Win8 avail at the moment.

Bakhtiar <tumagonx>
Project AdministratorIn charge of this item.
Wed 26 Mar 2014 07:20:56 PM UTC, comment #2:

Sorry about reporting on a soon-to-be obselete version- I just figured to give reporting the bug a try anyway.

Yes, similar issues happen on MyPaint 1.1 for windows, except that the lines are "zig-zaggier" with every brush stroke on top of having no pen pressure. I tried 1.1 out on my old Windows 7 PC as well, before it got busted. (I think I mentioned it on TumagonX's thread) and it was the same problem.

Alexandria <atsusakaneytza>
Wed 26 Mar 2014 10:33:26 AM UTC, comment #1:

Sadly this is an old version that I don't have the time to support, on an OS I don't run. Is this still happening under the recent dev builds by TumagonX? I notice you mention what seem to be different bugs on your post at

http://opensourcepack.blogspot.co.uk/2013/01/mypaint-and-pygi.html

Andrew Chadwick <achadwick>
Project Administrator
Wed 26 Mar 2014 09:43:15 AM UTC, original submission:

-I use MyPaint 1.0 on a Windows 8 ASUS laptop computer (4GB of RAM)
-I use Monoprice 4x3" and a 8x5" graphics tablets (UC Logic tablets) I never have both drivers installed at the same time, but I have up to date drivers for both tablets.
-Both tablets work in all other programs except MyPaint.
-MyPaint 1.0 worked fine on Windows 7 with my 4x3" tablet.
MyPaint clearly detects the exact specs of my tablet in the GTK dialog, but in the Test Input dialog, calls it the "core pointer."
-Changing the Tablet coordinate from "Window" to "Screen" does zilch for fixing the problem in question.
-Using the program without administrative privileges causes the pointer and its clicks to go undetected on the canvas (no stroke at all)
-Using the program WITH administrative privileges detects tablet strokes, but with no pressure.
-Any and all help with this issue would be appreciated.

Alexandria <atsusakaneytza>

 

Attached Files
file #20438:  MyPaint Error 1.png added by atsusakaneytza (123kB - image/png - These are screencaps of the errors in question (admin privileges))
file #20439:  MyPaint Error 2.png added by atsusakaneytza (225kB - image/png - These are screencaps of the errors in question (admin privileges))

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by tumagonx (Posted a comment)
  • -unavailable- added by achadwick (Posted a comment)
  • -unavailable- added by atsusakaneytza (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 11 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Fri 11 Jul 2014 10:45:17 PM UTCachadwickSeverity1 - Wish=>2 - Minor
      StatusWish=>None
      Open/ClosedClosed=>Open
    Fri 28 Mar 2014 02:06:49 AM UTCtumagonxOpen/ClosedOpen=>Closed
    Wed 26 Mar 2014 10:33:26 AM UTCachadwickSeverity4 - Important=>1 - Wish
      Priority5 - Normal=>3 - Low
      StatusNone=>Wish
      Assigned toNone=>tumagonx
      SummaryMyPaint\'s Pen Pressure doesn\'t work/Pointer not detected? (Screencaps included)=>[Windows, Old version] MyPaint's Pen Pressure doesn't work/Pointer not detected? (Screencaps included)
    Wed 26 Mar 2014 09:43:15 AM UTCatsusakaneytzaAttached File-=>Added MyPaint Error 1.png, #20438
      Attached File-=>Added MyPaint Error 2.png, #20439
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup