bugMyPaint - Bugs: bug #21878, [Windows] Brush jitters when...

 
 
Show feedback again

You are not allowed to post comments on this tracker with your current authentification level.

bug #21878: [Windows] Brush jitters when opening mypaint with tablet or when I use the mouse

Submitted by:  rodrigo carranza <arcr>
Submitted on:  Tue 01 Apr 2014 05:07:29 AM UTC  
 
Severity: 2 - MinorPriority: 5 - Normal
Status: Need InfoPrivacy: Public
Assigned to: NoneOpen/Closed: Open
Release: mypaint-1.1.0+git-e06d414_rev2Planned Release: None
Operating System: Windows 8

Wed 11 Jun 2014 11:37:18 AM UTC, comment #1:

Definitely Windows-specific. I can't reproduce it under any multi-input-device Linux here.

  • Which build are you using?
  • Could you clarify how you are determining the input device shifts please?

Also, I'm uncertain about the degree or nature of the "jitter" being experienced here - could you provide an example? BTW, "Jitter" is one of our brush engine settings - I'm assuming it's not that!

Is it a positional thing, or a choice-of-brush thing? Can it be made to go away temporarily by selecting the brush you want with the stylus, and then with the mouse, or is it always present?

If it's bouncing rapidly between input devices, it could also be switching between brushes. MyPaint remembers them based on the device you use, and that could be a source of Great Weirdness.

Perhaps the replacement input device selector I have tentatively planned may be a fix. We could certainly ignore events received from blacklisted devices during freehand input, as a workaround for this sort of bug elsewhere.

Andrew Chadwick <achadwick>
Project Administrator
Tue 01 Apr 2014 05:07:29 AM UTC, original submission:

The program operns fine when opened with mouse, but if I enter the program using the stylus the brushes jitter when painting.

When opening with mouse the program paints fine with tablet but, if I move my mouse, then the brush starts to jitter and there's no way to stop it.

When is working fine it only shows "Waltop tablet pressure stylus", but when starts working wrong it changes constantly between "System aggregated pointer" and "Waltop tablet pressure stylus" while painting.

I'm using a Genius G-pen M712 tablet.

Thanks.

rodrigo carranza <arcr>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by achadwick (Posted a comment)
  • -unavailable- added by arcr (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 3 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Wed 11 Jun 2014 11:37:18 AM UTCachadwickStatusNone=>Need Info
      SummaryBrush jitters when opening mypaint with tablet or when I use the mouse=>[Windows] Brush jitters when opening mypaint with tablet or when I use the mouse
    Wed 11 Jun 2014 11:37:17 AM UTCachadwickSeverity4 - Important=>2 - Minor
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup