bugFreeciv - Bugs: bug #21934, nuke destructs own city during...

 
 
Show feedback again

bug #21934: nuke destructs own city during unitwaittime

Submitted by:  None
Submitted on:  Sat 19 Apr 2014 12:51:48 PM UTC  
 
Category: clientSeverity: 3 - Normal
Priority: 5 - NormalStatus: Duplicate
Assigned to: pepeto <pepeto>Originator Email: -unavailable-
Open/Closed: ClosedRelease: 
Operating System: AnyPlanned Release: 2.4.4, 2.5.0, 2.6.0

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Wed 10 Sep 2014 12:10:16 PM UTC, SVN revision 26326:

Do nuke only if units have been reached the desired destination. Nuke cursor
also has the goto path support including the line drawn at mouse pos, and the
ability to use waypoints.

Reported anonymously

See gna bug #21932 & bug #21934

(Browse SVN revision 26326)

pepeto <pepeto>
Project MemberIn charge of this item.
Wed 10 Sep 2014 12:10:14 PM UTC, SVN revision 26325:

Do nuke only if units have been reached the desired destination. Nuke cursor
also has the goto path support including the line drawn at mouse pos, and the
ability to use waypoints.

Reported anonymously

See gna bug #21932 & bug #21934

(Browse SVN revision 26325)

pepeto <pepeto>
Project MemberIn charge of this item.
Wed 10 Sep 2014 12:10:05 PM UTC, SVN revision 26324:

Do nuke only if units have been reached the desired destination. Nuke cursor
also has the goto path support including the line drawn at mouse pos, and the
ability to use waypoints.

Reported anonymously

See gna bug #21932 & bug #21934

(Browse SVN revision 26324)

pepeto <pepeto>
Project MemberIn charge of this item.
Fri 05 Sep 2014 07:17:24 AM UTC, comment #1:

This ticket is actually some kind of duplicate of bug #21932. When the patches will be applied, the bug will be left.

pepeto <pepeto>
Project MemberIn charge of this item.
Sat 19 Apr 2014 12:51:48 PM UTC, original submission:

This is a similar bug to bug #21932 - but this one is caused by unitwaitime not techloss

Press turn done -

Using the shift N command to explode a nuke on an enemy city risks self destruction. An example is in the attached file. Point the nuke in London at the nearby city Berlin and fire it using the shift N command. Nothing happens. Now point it at the German worker next to Berlin. You destroy your own city, London.

A secondary issue here is that the nuke had moved immediately before turn done was hit and then the game was saved. Unitwaittime seems to have been lost during the save.

Anonymous

 

(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files
file #20522:  nuke-self-destructs-2.sav.bz2 added by None (20kB - application/x-bzip2)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by pepeto (Updated the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 7 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Wed 10 Sep 2014 12:10:40 PM UTCpepetoOpen/ClosedOpen=>Closed
    Fri 05 Sep 2014 07:17:24 AM UTCpepetoStatusNone=>Duplicate
      Operating SystemNone=>Any
      Planned Release=>2.4.4, 2.5.0, 2.6.0
    Fri 05 Sep 2014 07:17:23 AM UTCpepetoCategoryNone=>client
    Tue 02 Sep 2014 02:05:59 PM UTCpepetoAssigned toNone=>pepeto
    Sat 19 Apr 2014 12:51:48 PM UTCNoneAttached File-=>Added nuke-self-destructs-2.sav.bz2, #20522
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup