bugBattle for Wesnoth - Bugs: bug #22073, lua errors in LoW scenario 3

 
 
Show feedback again

bug #22073: lua errors in LoW scenario 3

Submitted by:  Chris Beck <involution>
Submitted on:  Fri 23 May 2014 05:52:16 AM UTC  
 
Category: BugSeverity: 3 - Normal
Priority: 5 - NormalItem Group:  None of the others
Status: PostponedPrivacy: Public
Assigned to: Fabian Müller <fendrin>Open/Closed: Open
Release: 1.13.0-devOperating System: Linux Mint 16

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Thu 05 Jun 2014 09:52:25 PM UTC, comment #6:

fendrin:

I don't think that's a good idea. We spent an enormous amount of time debugging the server and clients so that mp campaigns can work correctly in 1.12. LoW works correctly in almost all cases now except for this bug.

If you postpone this issue, then despite all this work we still will not have a mainline mp campaign that works when we release.

This bug looks like it should be very easy to fix compared to the bugs that we already fixed.

Chris Beck <involution>
Project Member
Thu 05 Jun 2014 02:55:06 PM UTC, comment #5:

I postpone this to after the 1.12 release then.

Fabian Müller <fendrin>
Project MemberIn charge of this item.
Fri 23 May 2014 02:47:52 PM UTC, comment #4:

i think this https://github.com/wesnoth/wesnoth/commit/16f08c46d277304283269ec0613df234eca22905 may be the cause ecause LoW s replace_map seems to expect the header to e present.

Anonymous
Fri 23 May 2014 02:33:37 PM UTC, comment #3:

Yeah you are right, it's 1.13 only. Sorry about that...

Revised bug report to reflect it.

I cannot reproduce in 1.11.14+dev, 900a93a.
Only in master 688747e.

Chris Beck <involution>
Project Member
Fri 23 May 2014 12:54:13 PM UTC, comment #2:

hm you are sure that this happens on 1.11.14+dev too ? If i remember correctly from "about a week" ago this is was 1.13 only issue.

Anonymous
Fri 23 May 2014 05:53:27 AM UTC, comment #1:

http://i.imgur.com/EUwaSTj.png

Chris Beck <involution>
Project Member
Fri 23 May 2014 05:52:16 AM UTC, original submission:

At the start of the scenario, there is a stall and a reported lua error appears in the lua "replace_map" function. This causes the scenario to use a much larger map than usual, and all of the elves to start in the river rather than near to their fortress. It also causes some messages and scripted movements not to make sense.

gfgtdf reported this earlier in testing a few revisions ago (about a week?), but I did not get it at that time. I tried deleting / reverting my preferences file, but I couldn't get it to work properly.

Attaching a screenshot and copy paste of the error log.

Chris Beck <involution>
Project Member

 

(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files
file #20794:  error.log added by involution (2kB - text/x-log)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by fendrin (Posted a comment)
  • -unavailable- added by gfgtdf (Updated the item)
  • -unavailable- added by involution (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 4 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Thu 05 Jun 2014 02:55:06 PM UTCfendrinStatusNone=>Postponed
    Wed 28 May 2014 07:44:55 PM UTCgfgtdfAssigned toNone=>fendrin
    Fri 23 May 2014 02:33:37 PM UTCinvolutionRelease1.11.14+dev=>1.13.0-dev
    Fri 23 May 2014 05:52:16 AM UTCinvolutionAttached File-=>Added error.log, #20794
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup