bugFreeciv - Bugs: bug #24873, Too easy for units on map to lose...

 
 
Show feedback again

bug #24873: Too easy for units on map to lose keyboard focus?

Submitted by:  Jacob Nevins <jtn>
Submitted on:  Sun Jul 24 11:29:07 2016  
 
Category: client-qtSeverity: 3 - Normal
Priority: 5 - NormalStatus: Need Info
Assigned to: NoneOpen/Closed: Open
Release: S2_5 r33261Operating System: Microsoft Windows
Planned Release: Contains string changes: None

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sun Aug 21 16:13:06 2016, comment #4:

Focus is lost somewhere when closing diplomacy meeting. Didn't investigated further yet.

mir3x <mir3x>
Project Member
Mon Aug 1 20:08:57 2016, comment #3:

This was a single-player game (local spawned server). I suppose it could have temporarily become unresponsive (it clearly didn't die completely). (But this was on my reasonably responsive Windows 7 machine, not the underpowered Win10 netbook.)

As I say, I thought I tried 'W', but don't know for sure.

Jacob Nevins <jtn>
Project Administrator
Mon Aug 1 17:49:16 2016, comment #2:

In cases like this it might be good to try w)ait as that one is handled completely client-side. If the focus unit changes with it, there's no problem in keyboard focus, but other keys are seemingly doing nothing because there's no updates from server received (for whatever reason that then would be)

Marko Lindqvist <cazfi>
Project Administrator
Mon Aug 1 17:36:07 2016, comment #1:

It looks like:
http://forum.freeciv.org/f/viewtopic.php?f=8&t=1941

And overall it looks like u were disconnected from server,
considering GriffonSpade cannot connect to network also,
mb reason of all this is some network qt issue.

mir3x <mir3x>
Project Member
Sun Jul 24 11:29:07 2016, original submission:

(This is going to be a rubbish bug report. Sorry.)

Using the S2_5 r32261 Windows installer and playing through the tutorial, I got myself into a state where numeric keypad keys and (I think) 'W' weren't causing the selected unit to do anything. I found it a bit hard to get out of this state, and I'm not sure how I achieved it in the end.

Possibly-relevant things:

  • At some point I had entered something (a server command) in the chatline and then pressed 'Tab' to take focus away from the chatline. I think this had focused one of the chatline/messages controls and I'd done something about that.
  • IIRC my flailing to try and get out of this included clicking on the unit to try to give it / the map focus (which usually helps) but it didn't help.

I haven't managed to work out exactly I got into this state.

Jacob Nevins <jtn>
Project Administrator

 

(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by cazfi (Posted a comment)
  • -unavailable- added by mir3x (Posted a comment)
  • -unavailable- added by jtn (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Error: not logged in

     

     

    No Changes Have Been Made to This Item
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup