bugFreeciv - Bugs: bug #25343, Decide minimum version of Qt...

 
 
Show feedback again

bug #25343: Decide minimum version of Qt supported

Submitted by:  Jacob Nevins <jtn>
Submitted on:  Mon Nov 28 00:27:28 2016  
 
Category: client-qtSeverity: 3 - Normal
Priority: 5 - NormalStatus: Fixed
Assigned to: mir3x <mir3x>Open/Closed: Closed
Release: Operating System: Any
Planned Release: 2.6.0, 3.0.0, 3.1Contains string changes: None

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Mon Jan 16 13:17:37 2017, SVN revision 34855:

Decide minimum version of Qt supported
Reported by Jacob Nevins

See bug #25343

(Browse SVN revision 34855)

mir3x <mir3x>
Project MemberIn charge of this item.
Mon Jan 16 13:17:28 2017, SVN revision 34854:

Decide minimum version of Qt supported
Reported by Jacob Nevins

See bug #25343

(Browse SVN revision 34854)

mir3x <mir3x>
Project MemberIn charge of this item.
Mon Jan 16 13:17:17 2017, SVN revision 34853:

Decide minimum version of Qt supported
Reported by Jacob Nevins

See bug #25343

(Browse SVN revision 34853)

mir3x <mir3x>
Project MemberIn charge of this item.
Fri Jan 13 08:02:50 2017, comment #2:

In case of S2_6, README.packaging should list the requirement bumped since S2_5.

Marko Lindqvist <cazfi>
Project Administrator
Wed Jan 11 17:06:56 2017, comment #1:

I added check for Qt5.2 during configure.
With Qt5.0 it fails to compile (missing <QtMath> header, Qcolor.name() and probably more)

(file #29654)

mir3x <mir3x>
Project MemberIn charge of this item.
Mon Nov 28 00:27:28 2016, original submission:

As of bug #25341, the minimum version of Qt5 required is 5.2, because of QWheelEvent::phase (a recent addition, and a dependency we could probably get rid of fairly easily as mentioned in that bug).

I don't know whether we need any other 5.2 stuff (I've been on 5.2.1 for a while).

We haven't documented a minimum Qt5 version, and we don't check for one at configure time.

This bug is to decide a minimum version and make sure we can compile with it. Absolute minimum work would be to simply document that we require 5.2.

Jacob Nevins <jtn>
Project Administrator

 

(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files
file #29679:  qt52_check-S26.patch added by mir3x (2kB - text/x-patch)
file #29654:  qt52_check.patch added by mir3x (983B - text/x-patch)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by cazfi (Posted a comment)
  • -unavailable- added by mir3x (Updated the item)
  • -unavailable- added by jtn (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Error: not logged in

     

     

    Follow 7 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Mon Jan 16 13:18:01 2017mir3xStatusReady For Test=>Fixed
      Assigned toNone=>mir3x
      Open/ClosedOpen=>Closed
    Fri Jan 13 12:06:37 2017mir3xAttached File-=>Added qt52_check-S26.patch, #29679
    Wed Jan 11 17:06:56 2017mir3xAttached File-=>Added qt52_check.patch, #29654
      StatusNone=>Ready For Test
      Planned Release2.6.0, 3.0.0=>2.6.0, 3.0.0, 3.1
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup