bugBattle for Wesnoth - Bugs: bug #5877, problems copying text to clipboard

 
 
Show feedback again

bug #5877: problems copying text to clipboard

Submitted by:  Patrick P <sapient>
Submitted on:  Tue 02 May 2006 07:46:08 PM UTC  
 
Category: BugSeverity: 2 - Minor
Priority: 5 - NormalItem Group: User Interface
Status: Ready For TestPrivacy: Public
Assigned to: Mark de Wever <mordante>Open/Closed: Closed
Release: 1.1.2Operating System: Windows XP

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Sun 23 Dec 2012 07:54:43 AM UTC, SVN revision 55930:

gui1: Restore focus to the original textbox after resending relevant events to its input target

This effectively fixes bug #5877, again. r55925 introduced quite a
regression in the form of switching the focus permanently as soon as the
user presses the modifier key in Shift+ and Shift+C, requiring
improbable typing skills to get e.g. a Shift+C event before a solitary
left or right Shift event.

(Browse SVN revision 55930)

Ignacio R. Morelle <shadowmaster>
Project Administrator
Sun 23 Dec 2012 06:21:25 AM UTC, comment #12:

I haven't setup a development environment on Windows to test this myself, so I'm marking it as Ready for Test.

Ignacio R. Morelle <shadowmaster>
Project Administrator
Sun 23 Dec 2012 06:19:56 AM UTC, SVN revision 55927:

Attaching bug #5877 to the changelog entry for r55924

(Browse SVN revision 55927)

Ignacio R. Morelle <shadowmaster>
Project Administrator
Sun 07 Feb 2010 09:35:41 PM UTC, comment #10:

The windows specific part of this bug(copying has the effect of placing the empty string in the clipboard) was fixed in revision 41013

Sergey Popov <loonycyborg>
Project Member
Mon 16 Feb 2009 07:28:27 PM UTC, comment #9:

Yes there is but the MP dialog still uses the old code, hope to fix it post 1.6.

Mark de Wever <mordante>
Project MemberIn charge of this item.
Mon 16 Feb 2009 12:09:10 AM UTC, comment #8:

Was something of this copy&paste stuff solved with the GUI changes? I think at least for Linux some copy&paste stuff was introduced some time ago in the 1.5.x series...

Nils Kneuper <ivanovic>
Project Administrator
Sat 09 Feb 2008 09:18:38 AM UTC, comment #7:

Ok I'll look at it post 1.4.

Mark de Wever <mordante>
Project MemberIn charge of this item.
Sat 09 Feb 2008 01:39:55 AM UTC, comment #6:

note: I am not actively taking bug/feature requests

assigning to Mordante

Patrick P <sapient>
Project Member
Fri 08 Feb 2008 10:26:28 PM UTC, comment #5:

It seems the history can't be focussed (for good a reason) and thus will never receive the ctrl-c. It would be nice to have to option to make a it copyable and if it receives a key other than ctrl-c it relays it to the proper focus object.

I want to look at it if Sapient doesn't want to.

Mark de Wever <mordante>
Project MemberIn charge of this item.
Wed 06 Feb 2008 10:26:07 PM UTC, comment #4:

I just had a short look at it in the MP lobby. The problem seems to be that the entry box has the focus and that text is copied. If I select text in both the entry box and the history and press ctrl-c the entry box is copied and not the history... Also selecting the history and pressing ctrl-c doesn't help.

Mark de Wever <mordante>
Project MemberIn charge of this item.
Thu 01 Nov 2007 10:19:58 PM UTC, comment #3:

If Sapient, who knows the GUI better than anybody, can't confirm this is SDL level, then my understanding of the bug report was probably erroneous. Reverting status to None and assigning to Sapient.

Eric S. Raymond <esr>
Project Member
Thu 01 Nov 2007 12:10:02 PM UTC, comment #2:

Copying from one line input text boxes like the save game dialog works fine. Copying from multiline textboxes like the chat log or the lobby chat doesn't seem to work at all.

I don't see how that leads to the conclusion that it is an SDL problem.

This is on debian btw.

Gunter Labes <soliton>
Project Member
Tue 30 Oct 2007 04:22:03 AM UTC, comment #1:

esr: are you confident this is an SDL problem? An explanatory comment would be nice before closing this.

Patrick P <sapient>
Project Member
Tue 02 May 2006 07:46:08 PM UTC, original submission:

Copying editbox text in WindowsXP has the effect of placing the empty string in the clipboard (or so it seems). Anything previously in the clipboard is wiped out. Copying scrolling text has no effect at all (for Windows or Linux).

This might be a good thing to work into the next stable release.

Patrick P <sapient>
Project Member

 

(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by shadowmaster (Updated the item)
  • -unavailable- added by loonycyborg (Posted a comment)
  • -unavailable- added by ivanovic (Posted a comment)
  • -unavailable- added by mordante (Posted a comment)
  • -unavailable- added by soliton (Posted a comment)
  • -unavailable- added by esr (Updated the item)
  • -unavailable- added by sapient (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 8 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Tue 26 Mar 2013 12:48:52 PM UTCshadowmasterOpen/ClosedOpen=>Closed
    Sun 23 Dec 2012 06:21:25 AM UTCshadowmasterStatusNone=>Ready For Test
    Sun 29 Jan 2012 10:03:34 PM UTCshadowmasterStatusPostponed=>None
    Sat 09 Feb 2008 09:18:38 AM UTCmordanteStatusNone=>Postponed
    Sat 09 Feb 2008 01:39:55 AM UTCsapientAssigned tosapient=>mordante
    Thu 01 Nov 2007 10:19:58 PM UTCesrStatusUpstream Problem=>None
      Assigned toNone=>sapient
    Mon 29 Oct 2007 09:49:35 PM UTCesrStatusNone=>Upstream Problem
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup