bugeclox - Bugs: bug #9166, Too many things escaped in the...

Show feedback again

bug #9166: Too many things escaped in the ALIASES command

Submitted by:  Jesse Keller <jkeller1ca>
Submitted on:  Sat 19 May 2007 04:36:45 PM UTC  
Category: doxyfile editorSeverity: 5 - Blocker
Priority: 7 - HighStatus: Duplicate
Privacy: PublicAssigned to: Andre Bossert <anb0s>
Open/Closed: ClosedEclipse Release: None
Release: 0.6.3Operating System: None
Fixed Release: None

Add a New Comment (Rich MarkupRich Markup):

You are not logged in

Please log in, so followups can be emailed to you.


Fri 10 Apr 2015 06:36:36 PM UTC, comment #3:

moved to https://github.com/anb0s/eclox/issues/67

Andre Bossert <anb0s>
Project AdministratorIn charge of this item.
Fri 22 Jun 2007 03:08:01 PM UTC, comment #2:

Well, I thought a way to solve that problem. I think it would be better eclox don't do any automatic character escape but only warns the user if any character shoulb be escaped.

So the user will be informaed that something may go wrong in what he entered and he is supposed to know how to handle this.

Implementation may start soon :)

Guillaume Brocker <gbrocker>
Project Administrator
Sat 19 May 2007 04:52:54 PM UTC, comment #1:

All right... I thought my automatic escaping would work better than this. I will check how to improve it.

Thank you for your bug submission.


Guillaume Brocker <gbrocker>
Project Administrator
Sat 19 May 2007 04:36:45 PM UTC, original submission:

Attempting to use the ALIASES command of DOXYGEN to add xrefitems.

The final Alias command I want in the Doxyfile should be:

ALIASES = "message=\xrefitem messages \"Message\" \"Messages\""

However, when using the GUI mode to edit the Doxyfile, I add an entry in the Aliases section with the following text:

message=\xrefitem messages "Message" "Messages"

When I do this, I get the following text in the Doxygen file:
ALIASES = "message=\\xrefitem messages \"Message\" \"Messages\""

...which doesn't work. Looks like the "\" before the xrefitem is being escaped. Only quotes need to be escaped for the ALIASES command.

The workaround is to hand-edit the file.

Jesse Keller <jkeller1ca>


(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):

No files currently attached


Depends on the following items: None found

Items that depend on this one: None found


Carbon-Copy List
  • -unavailable- added by anb0s (Updated the item)
  • -unavailable- added by gbrocker (Posted a comment)
  • -unavailable- added by jkeller1ca (Submitted the item)

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.


    Please enter the title of George Orwell's famous dystopian book (it's a date):



    Follow 9 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Fri 10 Apr 2015 06:36:36 PM UTCanb0sStatusConfirmed=>Duplicate
      Assigned toNone=>anb0s
    Tue 07 Apr 2015 09:05:38 AM UTCanb0sCategoryNone=>doxyfile editor
    Tue 24 Nov 2009 02:52:00 PM UTCgbrockerAssigned togbrocker=>None
    Sat 19 May 2007 04:52:54 PM UTCgbrockerSeverity3 - Normal=>5 - Blocker
      Priority5 - Normal=>7 - High
      Assigned toNone=>gbrocker
    Show feedback again

    Back to the top

    Powered by Savane 3.1-cleanup