bugCal3D - 3d character animation library - Bugs: bug #11499, cal3d can't be configured, no...

 
 
Show feedback again

bug #11499: cal3d can't be configured, no makefile

Submitted by:  None
Submitted on:  Mon 14 Apr 2008 10:08:01 PM UTC  
 
Category: NoneSeverity: 4 - Important
Priority: 5 - NormalStatus: None
Privacy: PublicAssigned to: None
Originator Email: -unavailable-Open/Closed: Open

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Wed 07 Jan 2009 11:21:36 PM UTC, comment #1:

In the Planeshift page you mentioned, it is said to comment the line AM_USE_UNITTESTCPP. That's why you get the error.

By the way I felt on some other troubles when I tried to build environment for Planeshift too.

I did have to install autoconf, automake, libtool package in order to build Cal3D.

Maybe this keep poeple away from frustration.

regards

Pali

Laurent Sulej <pali>
Mon 14 Apr 2008 10:08:01 PM UTC, original submission:

I am running kubuntu (gutsy) and tried to compile cal3d from source in order to compile PlaneShift.
For this I was following the compilation guide at
http://planeshift.svn.sourceforge.net/viewvc/*checkout*/planeshift/trunk/docs/compiling.html#compile

Everything went fine until I got into trouble here:
/home/user/development/cal3d$ autoreconf --install --force
/home/user/development/cal3d$ ./configure --prefix=/home/user/development/cal3d
/home/user/development/cal3d$ make
/home/user/development/cal3d$ make install

When I issued
/home/user/development/cal3d$ ./configure --prefix=/home/user/development/cal3d
It exited with the following error:
checking whether g++ supports -fno-rtti... yes
./configure: line 20126: syntax error near unexpected token `UNITTESTCPP,'
./configure: line 20126: ` PKG_CHECK_MODULES(UNITTESTCPP, unittest++ >= 0.1, unittest_enabled="yes", unittest_enabled="no" )'

this would be the relevant codepiece in ./configure (starting at line in question):
PKG_CHECK_MODULES(UNITTESTCPP, unittest++ >= 0.1, unittest_enabled="yes", unitte$
if test "$unittest_enabled" = "yes" ; then
CPPFLAGS="$CPPFLAGS $UNITTESTCPP_CFLAGS"
LIBS="$LIBS $UNITTESTCPP_LIBS"

As a result, there is no makefile to run make with.
How to resolve this problem?

Anonymous

 

(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by pali (Posted a comment)
  • -unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    No Changes Have Been Made to This Item
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup