bugpokersource - Bugs: bug #14143, dpkg -i python-poker-network ;...

 
 
Show feedback again

You are not allowed to post comments on this tracker with your current authentification level.

bug #14143: dpkg -i python-poker-network ; apt-get -f install failed

Submitted by:  Johan Euphrosine <proppy>
Submitted on:  Mon 17 Aug 2009 09:38:31 AM UTC  
 
Category: poker-networkSeverity: 3 - Normal
Priority: 1 - LaterStatus: Need Info
Privacy: PublicAssigned to: None
Open/Closed: Open

Tue 23 Feb 2010 05:54:44 PM UTC, comment #3:

Does this still happen with latest version of poker-network 1.7.7 or 2.0 ?

Johan Euphrosine <proppy>
Project Member
Mon 17 Aug 2009 11:43:25 AM UTC, comment #2:

Hi,

I also spotted the following non-fatal error:
Preconfiguring packages ...
/tmp/python-poker-network.config.17581: line 33: /usr/share/dbconfig-common/dpkg/config.mysql: No such file or directory
python-poker-network failed to preconfigure, with exit status 1

Johan Euphrosine <proppy>
Project Member
Mon 17 Aug 2009 10:23:32 AM UTC, comment #1:

Here is the outflop with set -ex at the beginning of /var/lib/dpkg/info/python-poker-network.postrm:
lenny:/usr/src# apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
python-poker-network

  1. upgraded, 0 newly installed, 1 to remove and 25 not upgraded.

1 not fully installed or removed.
After this operation, 1769kB disk space will be freed.
Do you want to continue [Y/n]? Y
(Reading database ... 19568 files and directories currently installed.)
Removing python-poker-network ...
+ '[' -f /usr/share/debconf/confmodule ']'
+ . /usr/share/debconf/confmodule
++ '[' '!' '' ']'
++ PERL_DL_NONLAZY=1
++ export PERL_DL_NONLAZY
++ '[' '' ']'
++ exec /usr/share/debconf/frontend /var/lib/dpkg/info/python-poker-network.postrm remove
+ '[' -f /usr/share/debconf/confmodule ']'
+ . /usr/share/debconf/confmodule
++ '[' '!' 1 ']'
++ '[' -z '' ']'
++ exec
++ '[' '' ']'
++ exec
++ DEBCONF_REDIR=1
++ export DEBCONF_REDIR
+ db_get python-poker-network/configure
+ _db_cmd 'GET python-poker-network/configure'
+ IFS=' '
+ printf '%s\n' 'GET python-poker-network/configure'
+ IFS='
'
+ read -r _db_internal_line
+ RET='10 python-poker-network/configure doesn'\''t exist'
+ case ${_db_internal_line%%[ ]*} in
+ return 10
dpkg: error processing python-poker-network (--remove):
subprocess post-removal script returned error exit status 10
Errors were encountered while processing:
python-poker-network
E: Sub-process /usr/bin/dpkg returned an error code (1)

Johan Euphrosine <proppy>
Project Member
Mon 17 Aug 2009 09:38:31 AM UTC, original submission:

lenny:/usr/src# dpkg -i python-poker-network_1.7.5-1_all.deb
Selecting previously deselected package python-poker-network.
(Reading database ... 19566 files and directories currently installed.)
Unpacking python-poker-network (from python-poker-network_1.7.5-1_all.deb) ...
dpkg: dependency problems prevent configuration of python-poker-network:
python-poker-network depends on python-central (>= 0.6.7); however:
Package python-central is not installed.
python-poker-network depends on python-poker-engine (>= 1.3.0); however:
Package python-poker-engine is not installed.
python-poker-network depends on python-twisted; however:
Package python-twisted is not installed.
python-poker-network depends on python-mysqldb; however:
Package python-mysqldb is not installed.
python-poker-network depends on python-soappy; however:
Package python-soappy is not installed.
python-poker-network depends on python-pyopenssl; however:
Package python-pyopenssl is not installed.
python-poker-network depends on python-simplejson; however:
Package python-simplejson is not installed.
python-poker-network depends on python-memcache; however:
Package python-memcache is not installed.
python-poker-network depends on libjson-perl; however:
Package libjson-perl is not installed.
python-poker-network depends on dbconfig-common; however:
Package dbconfig-common is not installed.
python-poker-network depends on apg; however:
Package apg is not installed.
python-poker-network depends on rsync; however:
Package rsync is not installed.
dpkg: error processing python-poker-network (--install):
dependency problems - leaving unconfigured
Processing triggers for man-db ...
Errors were encountered while processing:
python-poker-network
lenny:/usr/src# apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
python-crypto python-zopeinterface python-twisted-names python-twisted-core python-twisted-web python-mysqldb python-twisted-runner python-simplejson python-serial
python-pam python-openssl python-twisted-mail apg python-memcache python-soappy python-twisted-lore python-central python-twisted-conch python-pyopenssl python-twisted-news
python-twisted-words rsync python-twisted libjson-perl python-fpconst libjson-xs-perl dbconfig-common python-twisted-bin
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
apg dbconfig-common libjson-perl libjson-xs-perl python-central python-crypto python-fpconst python-memcache python-mysqldb python-openssl python-pam python-pyopenssl
python-serial python-simplejson python-soappy python-twisted python-twisted-bin python-twisted-conch python-twisted-core python-twisted-lore python-twisted-mail
python-twisted-names python-twisted-news python-twisted-runner python-twisted-web python-twisted-words python-zopeinterface rsync
Suggested packages:
python-crypto-dbg python-egenix-mxdatetime python-mysqldb-dbg python-openssl-doc python-openssl-dbg python-wxgtk2.8 python-wxgtk2.6 python-wxgtk python-twisted-bin-dbg
python-tk python-gtk2 python-glade2 python-qt3 python-profiler python-twisted-runner-dbg python-zopeinterface-dbg
The following packages will be REMOVED:
python-poker-network
The following NEW packages will be installed:
apg dbconfig-common libjson-perl libjson-xs-perl python-central python-crypto python-fpconst python-memcache python-mysqldb python-openssl python-pam python-pyopenssl
python-serial python-simplejson python-soappy python-twisted python-twisted-bin python-twisted-conch python-twisted-core python-twisted-lore python-twisted-mail
python-twisted-names python-twisted-news python-twisted-runner python-twisted-web python-twisted-words python-zopeinterface rsync

  1. upgraded, 28 newly installed, 1 to remove and 25 not upgraded.

1 not fully installed or removed.
Need to get 3968kB of archives.
After this operation, 17.4MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Get:1 http://ftp.fr.debian.org lenny/main python-central 0.6.8 [40.4kB]
Get:2 http://ftp.fr.debian.org lenny/main apg 2.2.3.dfsg.1-2 [52.8kB]
Get:3 http://ftp.fr.debian.org lenny/main dbconfig-common 1.8.39 [489kB]
Get:4 http://ftp.fr.debian.org lenny/main libjson-perl 2.07-1 [89.8kB]
Get:5 http://ftp.fr.debian.org lenny/main libjson-xs-perl 2.01-1+b1 [81.1kB]
Get:6 http://ftp.fr.debian.org lenny/main python-crypto 2.0.1+dfsg1-2.3+lenny0 [226kB]
Get:7 http://ftp.fr.debian.org lenny/main python-fpconst 0.7.2-4 [8756B]
Get:8 http://ftp.fr.debian.org lenny/main python-memcache 1.40-1 [17.1kB]
Get:9 http://ftp.fr.debian.org lenny/main python-mysqldb 1.2.2-7 [95.2kB]
Get:10 http://ftp.fr.debian.org lenny/main python-openssl 0.7-2 [88.9kB]
Get:11 http://ftp.fr.debian.org lenny/main python-pam 0.4.2-12 [12.8kB]
Get:12 http://ftp.fr.debian.org lenny/main python-pyopenssl 0.7-2 [9088B]
Get:13 http://ftp.fr.debian.org lenny/main python-serial 2.3-1 [45.0kB]
Get:14 http://ftp.fr.debian.org lenny/main python-simplejson 1.9.2-1 [53.1kB]
Get:15 http://ftp.fr.debian.org lenny/main python-soappy 0.12.0-4 [129kB]
Get:16 http://ftp.fr.debian.org lenny/main python-twisted-bin 8.1.0-4 [29.8kB]
Get:17 http://ftp.fr.debian.org lenny/main python-zopeinterface 3.3.1-7 [135kB]
Get:18 http://ftp.fr.debian.org lenny/main python-twisted-core 8.1.0-4 [920kB]
Get:19 http://ftp.fr.debian.org lenny/main python-twisted-web 8.1.0-1 [325kB]
Get:20 http://ftp.fr.debian.org lenny/main python-twisted-lore 8.1.0-1 [78.5kB]
Get:21 http://ftp.fr.debian.org lenny/main python-twisted-mail 8.1.0-2 [173kB]
Get:22 http://ftp.fr.debian.org lenny/main python-twisted-names 8.1.0-1 [52.4kB]
Get:23 http://ftp.fr.debian.org lenny/main python-twisted-news 8.1.0-1 [26.4kB]
Get:24 http://ftp.fr.debian.org lenny/main python-twisted-runner 8.0.0-1 [18.6kB]
Get:25 http://ftp.fr.debian.org lenny/main python-twisted-words 8.1.0-2 [213kB]
Get:26 http://ftp.fr.debian.org lenny/main rsync 3.0.3-2 [328kB]
Get:27 http://ftp.fr.debian.org lenny/main python-twisted-conch 1:8.1.0-1 [220kB]
Get:28 http://ftp.fr.debian.org lenny/main python-twisted 8.1.0-4 [10.6kB]
Fetched 3968kB in 1s (2799kB/s)
Preconfiguring packages ...
(Reading database ... 19745 files and directories currently installed.)
Removing python-poker-network ...
dpkg: error processing python-poker-network (--remove):
subprocess post-removal script returned error exit status 10
Processing triggers for man-db ...
Errors were encountered while processing:
python-poker-network
E: Sub-process /usr/bin/dpkg returned an error code (1)

Johan Euphrosine <proppy>
Project Member

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by proppy (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 2 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Tue 23 Feb 2010 05:54:44 PM UTCproppyStatusNone=>Need Info
    Mon 17 Aug 2009 09:38:52 AM UTCproppyCategoryNone=>poker-network
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup