bugMyPaint - Bugs: bug #19792, in the brush list editor,...

 
 
Show feedback again

You are not allowed to post comments on this tracker with your current authentification level.

bug #19792: in the brush list editor, impossible to drag a brush from a group to another one....

Submitted by:  grubert <grubert>
Submitted on:  Fri 08 Jun 2012 07:40:44 PM UTC  
 
Severity: 3 - NormalPriority: 5 - Normal
Status: Need InfoPrivacy: Public
Assigned to: NoneOpen/Closed: Open
Release: git master 6/6/2012Planned Release: None
Operating System: kunbutu 12.04

(Jump to the original submission Jump to the original submission)

Thu 18 Jul 2013 01:58:37 PM UTC, comment #6:

Perhaps same bug. When I start to move brush error raises
Traceback (most recent call last):
File "/home/ildar/.local/opt/mypaint-git/share/mypaint/gui/pixbuflist.py", line 165, drag_motion_cb(self=<BrushList object at 0x3eae690 (gui+brushselectionwindow+BrushList at 0x3e68ce0)>, widget=<BrushList object at 0x3eae690 (gui+brushselectionwindow+BrushList at 0x3e68ce0)>, context=<gtk.gdk.X11DragContext object at 0x7de70f0 (GdkX11DragContext at 0x540e150)>, x=236, y=185, time=143563847L)
action = None
source_widget = context.get_source_widget()
if self is source_widget:
variables: {'source_widget': (None, [])}
AttributeError: 'gtk.gdk.X11DragContext' object has no attribute 'get_source_widget'

debian sid an mypaint form git
python-gtk2 2.24.0-3+b1

Ильдар <akhil>
Sat 15 Dec 2012 10:35:12 PM UTC, comment #5:

On my tablet PC with Kubuntu 12.10 using the latest x64 build from the achadwick repo I have the same problem.

I can drag-and-drop brushes fine with the trackpad, but when using the stylus if the dragged brush crosses a grid boundary in the brush list before it leaves the bounds of the list, excepting the top and left grid boundaries, or it leaves the list bounds and re-enters it gets stuck within the bounds of the list (using the trackpad the brush can be freely dragged over grid boundaries, leave and re-enter without getting stuck).

Carl Olsson <surt>
Thu 19 Jul 2012 09:27:14 AM UTC, comment #4:

Hi,
I am not good enough in linux to do all this.
But what I did is to switch for Kunbutu 12.04 ( with kde ) to unbutu 12.04 ( non kde, if I understood well ).
then I install MyPaint git.
So it's a very fresh install, with all initial parameters.

And then, the bug was still here.

grubert <grubert>
Mon 16 Jul 2012 08:03:51 PM UTC, comment #3:

Hmm. What GTK theme are you using, and does changing that for your DE fix things? ISTR the some of the KDE-lookalike ones being fairly buggy when I last tried.

Relatedly, does the problem go away when you switch out of KDE? Try installing twm and xephyr, and run mypaint with the attached test wrapper:

This runs it without KDE, and without any nonstandard GTK theming, under an ancient window manager. Let me know if you still see the problem under the test wrapper.

(file #16115)

Andrew Chadwick <achadwick>
Project Administrator
Mon 16 Jul 2012 10:39:27 AM UTC, comment #2:

Hi,
I made a fresh install, the problem is always here.
There is not really much to add to explain the bug.
I made a screen capture to be more explicite, hope it helps.

And I tried with the window docked and undocked, it's the same.

And also tried the "Tab" trick, wich worked for the "mouse targeting bug", but it didn't solve this one.

(file #16113)

grubert <grubert>
Sat 14 Jul 2012 07:43:09 PM UTC, comment #1:

Can't reproduce this one. Can you give me some more information on how to make it happen? Ideally minimal steps from a completely fresh config:

I've tried dragging from the list of brush icons to the list of brush group names, and from one shift-clicked group to another (so that both groups are shown simultaneously). I can't reproduce this under Xubuntu 12.04.

If it doesn't happen with a fresh config, and it's still happening with your working setup, can you let me know whether there's any difference in numbers of brushes, numbers of visible brushes, numers of columns?

Andrew Chadwick <achadwick>
Project Administrator
Fri 08 Jun 2012 07:40:44 PM UTC, original submission:

...IF the brush you want to drag is not on the first line ( the most upper one ) of the group you want to drag from.

1-in a brush group, choose a brush not in the first line of the group and try to drag it in another group : impossible.

2- make it slide to the first line, and try to drag it to another group : possible.

grubert <grubert>

 

Attached Files
file #16115:  test-in-xephyr.sh added by achadwick (755B - application/x-sh)
file #16113:  screencap.jpg added by grubert (135kB - image/jpeg)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by akhil (Posted a comment)
  • -unavailable- added by surt (Posted a comment)
  • -unavailable- added by achadwick (Posted a comment)
  • -unavailable- added by grubert (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 3 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Mon 16 Jul 2012 08:03:51 PM UTCachadwickAttached File-=>Added test-in-xephyr.sh, #16115
    Mon 16 Jul 2012 10:39:27 AM UTCgrubertAttached File-=>Added screencap.jpg, #16113
    Sat 14 Jul 2012 07:43:09 PM UTCachadwickStatusNone=>Need Info
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup