bugFreeciv - Bugs: bug #19962, Lua Tile:set_label() does not...

 
 
Show feedback again

bug #19962: Lua Tile:set_label() does not update clients

Submitted by:  Jacob Nevins <jtn>
Submitted on:  Sat 21 Jul 2012 12:28:29 AM UTC  
 
Category: NoneSeverity: 3 - Normal
Priority: 5 - NormalStatus: None
Assigned to: NoneOpen/Closed: Open
Release: trunk r21593Operating System: None
Planned Release: 2.5.0

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sat 21 Jul 2012 12:28:29 AM UTC, original submission:

The tile_label() function added in patch #3136 and modified in bug #19957 doesn't do anything to push the updated tile to clients, so it's left until the next time the tile gets updated for another reason.

However, the obvious code fix causes trouble in the form of assertion failures when the script that assigns labels on the "map_generated" signal runs.

Jacob Nevins <jtn>
Project Administrator

 

(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by jtn (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    No Changes Have Been Made to This Item
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup