bugBattle for Wesnoth - Bugs: bug #20605, lua error after ending turn

 
 
Show feedback again

bug #20605: lua error after ending turn

Submitted by:  None
Submitted on:  Sun 10 Mar 2013 04:01:23 AM UTC  
 
Category: BugSeverity: 3 - Normal
Priority: 5 - NormalItem Group: Artificial Intelligence
Status: FixedPrivacy: Public
Assigned to: Matthias Schoeck <mattsc>Originator Email: -unavailable-
Open/Closed: ClosedRelease: 1.11.1
Operating System: Windows 7x64

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Tue 03 Sep 2013 02:27:15 AM UTC, comment #5:

I just tried a game of Experimental AI vs. Experimental AI on Weldyn Channel and got no error messages. So I assume that this is an old bug that was already fixed elsewhere.

As for the second problem, without additional information I also have to assume that it is fixed (as per the link I provided previously).

I'll mark this as "Fixed" and will close the report in a few days if no remaining problems are reported.

Matthias Schoeck <mattsc>
Project MemberIn charge of this item.
Fri 26 Jul 2013 04:22:35 PM UTC, comment #4:

You did not say under which circumstances this occurred, but based on the message, I assume that it was when you tried to use the Experimental AI with a non-mainline faction? If so, this is likely the same error as reported in this thread
http://forums.wesnoth.org/viewtopic.php?f=4&t=38871
which was due to a bug in the Experimental AI. It's fixed in 1.11.5.

Matthias Schoeck <mattsc>
Project MemberIn charge of this item.
Fri 26 Jul 2013 03:34:06 PM UTC, comment #3:

hello

I need help with...

Lua error - or 1.11.2/data/ai/lua/generic-recruit_engine.lua:145
attempt to perform arithmetic on field 'multiply'(a nil
value) stack traceback:
or 1.11.2/data/ai/lua/generic-recruit_engine.lua:145
in faction 'get_best_attack'
or 1.11.2/data/ai/lua/generic-recruit_engine.lua:235
in faction 'analyze_enemy_unit'
or 1.11.2/data/ai/lua/generic-recruit_engine.lua:427
in faction <or 1.11.2/data/ai/lua/
generic-recruit_engine .lua:399>
(...tail calls...)
[string"(...):rusher_recruit_exec({[randomness"]=...
"]:1:in main chunk

thanks

Arnold Brits <arnold>
Mon 11 Mar 2013 12:54:05 AM UTC, comment #2:

Hi. My guess is that the problem is with your code rather than with Wesnoth itself (the latter being what this bug tracker is about), but you need to provide more information (e.g. your code) in order for us to be certain about that. Most likely, the Wesnoth forums or IRC channels are a better audience for getting feedback on this, until we are sure that this really is a bug in Wesnoth itself.

Matthias Schoeck <mattsc>
Project MemberIn charge of this item.
Sun 10 Mar 2013 04:04:43 AM UTC, comment #1:

The map was Weldyn Channel.

Anonymous
Sun 10 Mar 2013 04:01:23 AM UTC, original submission:

I created a game with a single experimental ai. After ending my first turn I got all these lua errors. See the screenshot.

Anonymous

 

(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files
file #17417:  lua error.png added by None (529kB - image/png)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by arnold (Posted a comment)
  • -unavailable- added by shadowmaster (Updated the item)
  • -unavailable- added by mattsc (Posted a comment)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 5 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Tue 03 Sep 2013 02:27:15 AM UTCmattscStatusNeed Info=>Fixed
    Thu 27 Jun 2013 10:06:42 AM UTCshadowmasterOpen/ClosedOpen=>Closed
    Mon 11 Mar 2013 12:55:29 AM UTCmattscStatusNone=>Need Info
      Assigned toNone=>mattsc
    Sun 10 Mar 2013 04:03:29 AM UTCNoneAttached File-=>Added lua error.png, #17417
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup