bugMyPaint - Bugs: bug #20687, old config dir ~/.mypaint causes...

 
 
Show feedback again

You are not allowed to post comments on this tracker with your current authentification level.

bug #20687: old config dir ~/.mypaint causes incomprehensible errors

Submitted by:  Cedric sodhi <manday>
Submitted on:  Sat 30 Mar 2013 09:29:08 PM UTC  
 
Severity: 3 - NormalPriority: 5 - Normal
Status: Works For MePrivacy: Public
Assigned to: NoneOpen/Closed: Open
Release: git masterPlanned Release: None
Operating System: 

Thu 04 Apr 2013 03:27:26 PM UTC, comment #4:

This is probably something other than Cairo support given the error relates to treeview models - perhaps your recompile fixed that too - but it would be tricky to nail down, I think. Closing WORKSFORME given that the problem has gone away with a more complete GObject-system/Python build.

Andrew Chadwick <achadwick>
Project Administrator
Mon 01 Apr 2013 01:23:32 PM UTC, comment #3:

After I corrected the PyGObject build to be compiled against cairo, as described in #20688, the error does no longer occur.

Cedric sodhi <manday>
Mon 01 Apr 2013 08:20:37 AM UTC, comment #2:

Gentoo Linux, git master. I still have the offending config dir, I attached it as a tar'ed file (it's a .mypaint directory, so you probably won't see it without ls -a after extracting). I'll bisect as soon as I can.

Cedric sodhi <manday>
Sun 31 Mar 2013 10:02:28 PM UTC, comment #1:

Cool error. Zero's certainly in the range mentioned...

What operating system and version are you using, please?

Unfortunately I can't reproduce this one out unless I know what was in your old config and user data files. Did you change any settings or do anything which might provoke a bug with the display of the layer visibility state on startup?

If you have backups and know git well, please use bisect to identify the troublesome commit. I don't think it's to do with the migration to XDG config dirs.

Andrew Chadwick <achadwick>
Project Administrator
Sat 30 Mar 2013 09:29:08 PM UTC, original submission:

Only after I deleted the old ~/.mypaint, mypaint would start. Before that, it would give me strange errors like

Traceback (most recent call last):
File "/home/manday/local/share/mypaint/gui/layerswindow.py", line 353, in layer_visible_datafunc
layer = model.get_value(tree_iter, 0)
File "/usr/lib64/python2.7/site-packages/gi/types.py", line 43, in function
return info.invoke(*args, **kwargs)
ValueError: 0 not in range -2147483648 to 2147483647

Cedric sodhi <manday>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by achadwick (Posted a comment)
  • -unavailable- added by manday (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 3 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Thu 04 Apr 2013 03:27:26 PM UTCachadwickStatusNeed Info=>Works For Me
    Sun 31 Mar 2013 10:02:28 PM UTCachadwickSeverity4 - Important=>3 - Normal
      StatusNone=>Need Info
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup