bugBattle for Wesnoth - Bugs: bug #20815, Game crashes while trying to...

 
 
Show feedback again

bug #20815: Game crashes while trying to display rare unicode characters in the beginning of the string.

Submitted by:  None
Submitted on:  Wed 15 May 2013 04:53:29 PM UTC  
 
Category: BugSeverity: 3 - Normal
Priority: 5 - NormalItem Group: Multiplayer
Status: ConfirmedPrivacy: Public
Assigned to: NoneOriginator Email: -unavailable-
Open/Closed: OpenRelease: 1.10.5
Operating System: Linux

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sun 02 Mar 2014 08:14:59 AM UTC, comment #4:

Confirmed but it only effected the load saved game and the Addon Manager once connected to the server for me in 1.11.10

If this is really a GUI 1 issue both should be moved to GUI 2 as a fix.

Real Name <aishiko>
Wed 03 Jul 2013 05:17:45 PM UTC, comment #3:

So after some more searching this seems to be gui 1 linked since the new mp lobby doesn't suffer this issue while the addon server search bar does.

Thibault Févry <iwontbecreative>
Project Member
Wed 03 Jul 2013 04:58:50 PM UTC, comment #2:

The bug can also happen while setting up the game name in multiplayer or in chat in multiplayer.

Here's a backtrace with gdb from the bug, hope it helps.

GNU gdb (Ubuntu/Linaro 7.4-2012.04-0ubuntu2.1) 7.4-2012.04
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.launchpad.net/gdb-linaro/>...
Reading symbols from /home/thibault/wesnoth/wesnoth-old/wesnoth...(no debugging symbols found)...done.
(gdb) run
Starting program: /home/thibault/wesnoth/wesnoth-old/wesnoth
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffecce2700 (LWP 20354)]
Battle for Wesnoth v1.11.5+dev (08f3e12-Clean)
Started on Wed Jul 3 17:56:06 2013

Automatically found a possible data directory at /home/thibault/wesnoth/wesnoth-old

Data directory: /home/thibault/wesnoth/wesnoth-old
User configuration directory: /home/thibault/.config/wesnoth
User data directory: /home/thibault/.local/share/wesnoth/1.11
Cache directory: /home/thibault/.cache/wesnoth
Checking video mode: 1615x997x32...
setting mode to 1615x997x32
20130703 17:56:06 error config: hotkey key '__none__' invalid
20130703 17:56:06 error config: hotkey key '__none__' invalid
[New Thread 0x7fffeadc5700 (LWP 20355)]
[New Thread 0x7fffea5c4700 (LWP 20356)]
[Thread 0x7fffea5c4700 (LWP 20356) exited]
20130703 17:56:13 error config: hotkey key '__none__' invalid
20130703 17:56:13 error config: hotkey key '__none__' invalid

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff48ab972 in ?? () from /lib/x86_64-linux-gnu/libc.so.6
(gdb) bt
#0 0x00007ffff48ab972 in ?? () from /lib/x86_64-linux-gnu/libc.so.6
#1 0x00007ffff7940d5f in ?? () from /usr/lib/x86_64-linux-gnu/libSDL-1.2.so.0
#2 0x00007ffff7941733 in ?? () from /usr/lib/x86_64-linux-gnu/libSDL-1.2.so.0
#3 0x00007ffff7958bd8 in SDL_LowerBlit () from /usr/lib/x86_64-linux-gnu/libSDL-1.2.so.0
#4 0x00007ffff7958e4f in SDL_UpperBlit () from /usr/lib/x86_64-linux-gnu/libSDL-1.2.so.0
#5 0x0000000000ba7be6 in gui::textbox::draw_contents() ()
#6 0x0000000000ba9e81 in gui::widget::draw() ()
#7 0x0000000000b143ce in events::raise_draw_event() ()
#8 0x000000000053a715 in run_lobby_loop(display&, mp::ui&) [clone .constprop.461] ()
#9 0x000000000053cf3b in enter_lobby_mode(game_display&, config const&, mp::chat&, config&) [clone .constprop.460] ()
#10 0x000000000053ddfc in mp::start_client(game_display&, config const&, std::string const&) ()
#11 0x0000000000474f18 in game_controller::play_multiplayer() ()
#12 0x000000000043537f in do_gameloop(int, char**) ()
#13 0x000000000041eea5 in main ()

Thibault Févry <iwontbecreative>
Project Member
Wed 03 Jul 2013 04:44:31 PM UTC, comment #1:

Can confirm this bug on fresh trunk install.

Thibault Févry <iwontbecreative>
Project Member
Wed 15 May 2013 04:53:29 PM UTC, original submission:

While playing the game:
1)Open the chat
2)Copy-paste "( ͡° ͜ʖ ͡°) " there (without ")
3)Start removing symbols from the beginning (press "home", then "delete" several times)
???
4)Game crashes

Anonymous

 

(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by aishiko (Posted a comment)
  • -unavailable- added by iwontbecreative (Posted a comment)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follows 1 latest change.

    Date Changed By Updated Field Previous Value => Replaced By
    Wed 03 Jul 2013 04:44:31 PM UTCiwontbecreativeStatusNone=>Confirmed
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup