bugMyPaint - Bugs: bug #20883, [GTK] Mypaint Git Master and...

 
 
Show feedback again

You are not allowed to post comments on this tracker with your current authentification level.

bug #20883: [GTK] Mypaint Git Master and problems with UC-Logic WA60

Submitted by:  jose americo gobbo <americo>
Submitted on:  Sun 09 Jun 2013 09:22:52 PM UTC  
 
Severity: 3 - NormalPriority: 5 - Normal
Status: In ProgressPrivacy: Public
Assigned to: NoneOpen/Closed: Closed
Release: Mypaint 1.1 git masterPlanned Release: None
Operating System: Ubuntu 12.04 Gnome-remix

(Jump to the original submission Jump to the original submission)

Sun 29 Jun 2014 12:19:58 AM UTC, comment #16:

Hi everyone --

Joshua migrated this bug to github (thanks for that!) and I think we need to get working on it.

New location https://github.com/mypaint/mypaint/issues/29

I'm closing the bug report here on Gna!, but the new bug refers back to is and there's a nice summery of the investigation over there now. Could everyone interested in this bug please subscribe to it on github? Thanks.

Andrew Chadwick <achadwick>
Project Administrator
Sat 31 May 2014 05:22:40 PM UTC, comment #15:

Hi,
I've used a tip to Krita last year... perhaps isn't more necessary, but with mypaint this tip works fine. You can read this thread:http://forum.kde.org/viewtopic.php?f=139&t=98347&p=254824&hilit=viktoria#p254824.
In my case works fine, a twa60 (monoprice 10x6).
This tip force the uc-logic tablet works as a wacom tablet.
I've attached an small howto, in Portuguese, but I think that is easy to understand the main steps.

(file #20886)

jose americo gobbo <americo>
Sat 31 May 2014 01:00:08 PM UTC, comment #14:

Okay, this is still sitting here with "need info", but I'm not sure what is actually needed. I tried to provide some extra information and confirmation that it's happening to other users and other devices, but the bug is still sitting with the same status a month later, and the bug itself is nearly a year old. What is it you need here?

As best I can tell it's not a driver or device problem, because it works fine with multiple gtk2 apps (Gimp, Inkscape, older MyPaint), as well as Krita.

It's either a problem with Gtk3 or with MyPaint, and both sides are saying "You should talk to the other guys", which means that a piece of software that's generally very nice to use is sitting around worthless to a portion of its intended user base because neither side is taking responsibility for the problem.

On the gtk3 side, this was the last thing said on the matter, six months ago:

Does this mean that MyPaint is dealing with the information incorrectly, or that Gtk3 is? If the latter, is there not something a MyPaint dev could do to help convince the Gtk side that this needs to be fixed?

I'm sorry if this sounds pushy, but just leaving a bug at "Need Info" for a year is ridiculous. Would the problem have gotten more attention if I'd opened a duplicate report instead of trying to do the responsible thing and find a similar bug to add information to?

I'd like to see MyPaint be usable again, and I've tried reporting two very nasty bugs with the Gtk3 version recently in an effort to help make problems known and get them fixed, but I can't fix them myself and it feels like bug reports are just being ignored now.

Development was so lively and quick to communicate in the past. What happened? This isn't like you guys. It's like the move to Gtk3 took away your passion for the project. :(

Joshua Tyler <marand>
Sun 13 Apr 2014 01:54:14 AM UTC, comment #13:

I'm experiencing the same problem with the Monoprice 19" pen display I got a few days ago. ( http://www.monoprice.com/Product/?c_id=113&cp_id=11314&cs_id=1131401&p_id=10707&seq=1&format=3 ) It uses Huion hardware (uc-logic based) and kernel driver (hid-huion.ko), so there are likely other devices by them that have the same problems.

In my case, it's more pronounced than the video he posted, and I get similar gaps in "xinput test"

Tested with 3.10.7 and 3.12.0 of libgtk-3-dev on Debian-testing. I realise it's probably a gtk issue and not a mypaint one, but I don't use many gtk3 apps, especially with a pen, so this was the best option I had for reporting the issue. Plus it lets you know that it's not just a one-off problem with one person.

I'll just have to stick with a gtk2 build until this and the keybinding thing are fixed.

(file #20511)

Joshua Tyler <marand>
Thu 24 Oct 2013 02:52:01 AM UTC, comment #12:

The same behavior is present on elementary OS 0.2 Luna with Xfce.
Short video about this bug: http://www.youtube.com/watch?v=lGhwmvGfp64&feature=youtu.be

jose americo gobbo <americo>
Thu 04 Jul 2013 04:27:35 PM UTC, comment #11:

Ok Martin, I've tryied compile gtk 3.0 in /opt but is very hard for me, some errors after 'make'. Now I've open a bug on gnome.bugzilla: https://bugzilla.gnome.org/show_bug.cgi?id=703610

I've thought interesting freeze MyPaint 1.1.0+git (actual version ppa) as a secondary branch with gtk+2 for all, and perhaps, to create another ppa branch with gtk+3.
Thanks,
americo

jose americo gobbo <americo>
Thu 04 Jul 2013 04:30:12 AM UTC, comment #10:

Sounds like you really should talk to GTK or even Xorg people.

You can compile&install GTK to a different --prefix directory, and set the LD_LIBRARY_PATH environment variable before you start mypaint. To verify, get the PID of MyPaint after it has started, and use 'cat /proc/<pid>/maps'.

Martin Renold <martinxyz>
Project Administrator
Wed 03 Jul 2013 08:56:59 PM UTC, comment #9:

With different versions of gtk-3 the behavior is the same:

On ubuntu gnome 12.10
Version: 3.6.2-0ubuntu1~ubuntu12.10.2

On ubuntu gnome 13.04
Version: 3.6.4-0ubuntu8

On ubuntu gnome 13.10 alpha 1
Version: 3.8.2-0ubuntu7

Isn't possible downgrading without a bit confusion on my box... I'm trying install another version in /opt... for my tests...
Is possible to link another gtk version for the git mypaint versions?

jose americo gobbo <americo>
Sun 30 Jun 2013 05:21:53 PM UTC, comment #8:

It's a bit hard to tell for sure, but judging from your "testinput" video I would say this is much too irregular.

If so, the problem is clearly not coming from MyPaint. Try reporting it on the GTK+ bugtracker with your "testinput" test case and the exact GTK version. It could also be just another symptom of this bug: https://bugzilla.gnome.org/show_bug.cgi?id=702392

If it is, then downgrading to an older GTK3 should help. But I can reproduce that bug here, but not the "broken up" lines that you're seeing in MyPaint. My "testinput" pattern looks a bit broken up too (because of the low frame rate), but much more regular than yours.

Martin Renold <martinxyz>
Project Administrator
Fri 28 Jun 2013 12:24:24 AM UTC, comment #7:

Now I've made again the xinput test. Is attached the log [xinput-test.txt] and the image [xinput-test.jpg] that is produced during this test.

(file #18179, file #18180)

jose americo gobbo <americo>
Thu 27 Jun 2013 02:36:27 AM UTC, comment #6:

I did the last test with 'testinput' of gtk3.
In this test the stroke isn't continue... I've made a little video:
https://www.youtube.com/watch?v=L_Iqs-bGWaI

jose americo gobbo <americo>
Sat 15 Jun 2013 03:03:39 PM UTC, comment #5:

Concerning terminal3.png, do you get those "leave_notify" and "enter_notify" events displayed in the middle of a stroke, or did you actually leave/enter the window?

These events concerning they occur while you're making the stroke on canvas.

I'm preparing another box... to make the testinput, as we need compiling all Gtk ambient, I've fear that to can causes problems in my work box.

jose americo gobbo <americo>
Sat 15 Jun 2013 09:09:15 AM UTC, comment #4:

If you can, please try the GTK3 tablet test application:
http://wiki.mypaint.info/Development/Debugging_Tablet_Issues#Testing_GTK3_tablet_support

Concerning terminal3.png, do you get those "leave_notify" and "enter_notify" events displayed in the middle of a stroke, or did you actually leave/enter the window?

Martin Renold <martinxyz>
Project Administrator
Mon 10 Jun 2013 02:04:28 PM UTC, comment #3:

The videos:
+ Mypaint ppa with UC-Logic-WA60
https://www.youtube.com/watch?v=evQP258aHMs

+ Mypaint git master with UC-Logic-WA60
https://www.youtube.com/watch?v=MnNbCo2dWlk

jose americo gobbo <americo>
Mon 10 Jun 2013 02:00:29 PM UTC, comment #2:

I've made the Debugging_Tablet_Issues with my UC-Logic-WA60 (monoprice). The screenshots of terminal test are attached below.
I've made also two short videos to demonstrate the strange behavior.

(file #18074, file #18075)

jose americo gobbo <americo>
Mon 10 Jun 2013 04:18:55 AM UTC, comment #1:

Please try to get more information about what goes wrong. Here are some things to check: http://wiki.mypaint.info/Development/Debugging_Tablet_Issues

Martin Renold <martinxyz>
Project Administrator
Sun 09 Jun 2013 09:22:52 PM UTC, original submission:

With the last master on Git, my tablet UC-LOGIC WA60 don't work well... the stroke is descontinued.
The test is all with the same brush.

With the ppa version is all ok.

To understand better I've attached 2 images:
1. mypaint git master with wacom intuos2 (works fine)
2. idem with UC-LOGIC WA60 (don't work well)

jose americo gobbo <americo>

 

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by achadwick (Posted a comment)
  • -unavailable- added by marand (Updated the item)
  • -unavailable- added by martinxyz (Posted a comment)
  • -unavailable- added by americo (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 13 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sun 29 Jun 2014 12:19:58 AM UTCachadwickStatusNeed Info=>In Progress
      Open/ClosedOpen=>Closed
    Sat 31 May 2014 05:22:40 PM UTCamericoAttached File-=>Added monoprice-on-krita.txt, #20886
    Sun 13 Apr 2014 01:54:14 AM UTCmarandAttached File-=>Added mypaint-stroke-issue.png, #20511
    Sun 30 Jun 2013 05:21:53 PM UTCmartinxyzSummaryMypaint Git Master and problems with UC-Logic WA60=>[GTK] Mypaint Git Master and problems with UC-Logic WA60
    Fri 28 Jun 2013 12:24:24 AM UTCamericoAttached File-=>Added xinput-test.txt, #18179
      Attached File-=>Added xinput-test.jpg, #18180
    Mon 10 Jun 2013 02:01:57 PM UTCamericoAttached File-=>Added bug-uclogicwa60-mypaint-git-master_terminal3.png, #18076
    Mon 10 Jun 2013 02:00:29 PM UTCamericoAttached File-=>Added bug-uclogic-wa60-mypaint-git-master_terminal1.png, #18074
      Attached File-=>Added bug-uclogicwa60-mypaint-git-master_terminal2.png, #18075
    Mon 10 Jun 2013 04:18:55 AM UTCmartinxyzStatusNone=>Need Info
    Sun 09 Jun 2013 09:22:52 PM UTCamericoAttached File-=>Added mypaint-master_with-wacom-intuos2_test-brush.jpg, #18064
      Attached File-=>Added mypaint-master_with-uclogic-intuos2_test-brush.jpg, #18065
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup