bugBattle for Wesnoth - Bugs: bug #20923, Intermittent crash (runtime error)...

 
 
Show feedback again

bug #20923: Intermittent crash (runtime error) when using planning mode

Submitted by:  MikeBruce <acousticbruce>
Submitted on:  Fri 21 Jun 2013 12:49:52 AM UTC  
 
Category: BugSeverity: 4 - Important
Priority: 5 - NormalItem Group: Whiteboard
Status: NonePrivacy: Public
Assigned to: Gabriel Morin <gabba>Open/Closed: Open
Release: 1.10.6 stableOperating System: Win 7 64bit

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sat 22 Jun 2013 05:23:08 PM UTC, comment #3:

There are ways to provide more detail, other than a deterministic procedure. They are not as good as a deterministic procedure, but still better than just the error message. One the comes to mind is a screenshot showing the state of the game (map and information panels) when the error occurs. Sort of like what you did, except not cropped to just the error message...

For others' reference, the error messages are the following assertion failures.
1) attacking_unit (in whiteboard\manager.cpp, line 840)
2) px != 0 (in shared_ptr.hpp)
3) fake_units_.size() == 1 (in whiteboard\manager.cpp, line 820)
4) move_arrows_.size() == 1 (in whiteboard\manager.cpp, line 819)

J Tyne <jamit>
Project Member
Fri 21 Jun 2013 05:51:55 PM UTC, comment #2:

It is an intermittent problem in a planning mode only. It only happens when you execute a plan. But sometimes hense the word intermittent.

I was playing multiplayer when it happened. This is as detailed as it gets.

thanks.

I have a single player campaign going so i will put it on planning mode to see if it happens again in single player.

MikeBruce <acousticbruce>
Fri 21 Jun 2013 04:17:50 PM UTC, comment #1:

forum thread: http://forums.wesnoth.org/viewtopic.php?f=4&t=39000

Well, your screenshots show various assertion failures. This unfortunately doesn't tell a lot; to be able to fix a bug at its root there should be a deterministic detailed step-by-step description of how to reproduce it...

Anonymissimus <anonymissimus>
Project Member
Fri 21 Jun 2013 12:49:52 AM UTC, original submission:

I found a bug that ONLY happens in planning mode. It is a intermittent problem. I played this game a year or 2 ago with a different computer and had the same issue.

What happens is in preferences you click planning mode and it works great for the most part but when you initiate or end turn so they all initiate, there sometimes is a runntime error.

So this time I decided to take the time and tell you about the issue. No way to copy and paste (good job MS) so I did screen shots.

I attached 4 screenshots.

E6400 2.66Ghz
4GB Ram
Nvidea 160M Graphics card

MikeBruce <acousticbruce>

 

(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files
file #18125:  Wesnoth (only happens with plan mode).bmp added by acousticbruce (434kB - image/bmp - No copy and paste because you cannot highlight the text. So I did screenshots)
file #18126:  wesnoth error 2.bmp added by acousticbruce (476kB - image/bmp - No copy and paste because you cannot highlight the text. So I did screenshots)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by jamit (Posted a comment)
  • -unavailable- added by anonymissimus (Posted a comment)
  • -unavailable- added by acousticbruce (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 5 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Fri 21 Jun 2013 04:17:50 PM UTCanonymissimusAssigned toNone=>gabba
    Fri 21 Jun 2013 01:07:18 AM UTCacousticbruceAttached File-=>Added wesnoth error 3.bmp, #18127
      Attached File-=>Added wesnoth error 4.bmp, #18128
    Fri 21 Jun 2013 12:49:52 AM UTCacousticbruceAttached File-=>Added Wesnoth (only happens with plan mode).bmp, #18125
      Attached File-=>Added wesnoth error 2.bmp, #18126
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup