patchFreeciv - Patches: patch #4477, Better configure check for...

 
 
Show feedback again

patch #4477: Better configure check for detection of unknown compiler options

Submitted by:  Marko Lindqvist <cazfi>
Submitted on:  Wed 05 Feb 2014 10:36:27 PM UTC  
 
Category: bootstrapPriority: 5 - Normal
Status: NonePrivacy: Public
Assigned to: NoneOpen/Closed: Open
Planned Release: 

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Wed 12 Feb 2014 12:51:22 AM UTC, comment #1:

Options supported by gcc aren't making this easy - the way I hoped to fix this doesn't work.

Marko Lindqvist <cazfi>
Project Administrator
Wed 05 Feb 2014 10:36:27 PM UTC, original submission:

jtn in patch #4421:

> I've noticed that whenever I get a -Werror build failure from
> my (GCC 4.6.3) toolchain, I get an additional complaint about
> this warning option


...

> cc1: error: unrecognized command line option "-Wno-tautological-compare"


...

> it only happens if the build was going to fail anyway


The last point is the problem exactly. When configure tests if the compiler supports the option, compiler does not complain.

Marko Lindqvist <cazfi>
Project Administrator

 

(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by cazfi (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 3 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Wed 12 Feb 2014 12:51:22 AM UTCcazfiStatusIn Progress=>None
      Planned Release2.4.3, 2.5.0, 2.6.0=>
      SummaryBetter configure check for detection unknown compiler options=>Better configure check for detection of unknown compiler options
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup