helpsmbldap-tools - Support: sr #2937, Unable to use smbldap-tools if...

 
 
Show feedback again

sr #2937: Unable to use smbldap-tools if perl use strict

Submitted by:  Saulo Soares de Toledo <saulotoledo>
Submitted on:  Thu 12 Jul 2012 02:29:50 PM UTC  
 
Category: NonePriority: 5 - Normal
Severity: 4 - ImportantStatus: None
Privacy: PublicAssigned to: None
Open/Closed: OpenOperating System: GNU/Linux

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Thu 12 Jul 2012 02:29:50 PM UTC, original submission:

I'm using Debian testing base system with compiled smbldap-tools 0.9.8 (debian version is 0.9.7).

In this version, the file /usr/share/perl5/Convert/ASN1/_encode.pm has "use strict;" at line 10, and smbldap-tools returns the error:

Can't use string ("['username','uidNumber','uid']") as an ARRAY ref while "strict refs" in use at /usr/share/perl5/Convert/ASN1/_encode.pm line 269.

Without "use strict;", smbldap-tools works correctily.

Saulo Soares de Toledo <saulotoledo>

 

(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by saulotoledo
  • -unavailable- added by saulotoledo (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follows 1 latest change.

    Date Changed By Updated Field Previous Value => Replaced By
    Thu 12 Jul 2012 02:29:51 PM UTCsaulotoledoCarbon-Copy-=>Added -unavailable-
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup