helpGna! Administration - Support: sr #3126, New "Content Encoding...

 
 
Show feedback again

sr #3126: New "Content Encoding Error" without changing HTML files

Submitted by:  Alexis Bienvenüe <jojo_boulix>
Submitted on:  Mon 03 Mar 2014 01:08:02 PM UTC  
 
Category: HomepagesPriority: 5 - Normal
Severity: 3 - NormalStatus: None
Privacy: PublicAssigned to: Beuc <beuc>
Open/Closed: OpenOperating System: Any / Non-Specific

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Mon 10 Mar 2014 07:35:57 PM UTC, comment #12:

Yes, I had to disable mod_deflate, short of alternatives :/
It would nice to report this to the Apache httpd project directly.

Beuc <beuc>
Site AdministratorIn charge of this item.
Mon 10 Mar 2014 06:49:10 PM UTC, comment #11:

Thanks!
So you disabled mod_deflate?

Alexis Bienvenüe <jojo_boulix>
Sat 08 Mar 2014 10:46:43 AM UTC, comment #10:

I filed:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=741082

For the encoding issue, can you file a new support request, (apparently the value in '<!--#set var="FIL" value="XXX"-->' is double-UTF-8-encoded, but this is a different issue entirely) ?

Beuc <beuc>
Site AdministratorIn charge of this item.
Wed 05 Mar 2014 05:25:53 PM UTC, comment #9:

There is no .htaccess file, and I don't see any special things.
Sorry I'm not very responsive this week, this will be better from sunday. Then I will also try to investigate locally.

Alexis Bienvenüe <jojo_boulix>
Wed 05 Mar 2014 05:46:57 AM UTC, comment #8:

For reference, here is the google cache on 14 Feb 2014.
http://webcache.googleusercontent.com/search?q=cache:sgzSlb1s4lkJ:home.gna.org/auto-qcm/index.ja+&cd=11&hl=en&ct=clnk

Hiroto Kagotani <khiroto>
Tue 04 Mar 2014 10:58:57 PM UTC, comment #7:

Are there .htaccess or any other site specific configuration file?

By the way, there is another difference between before and after the change, though I am not sure the change is related with this problem. auto-qcm's Japanese site has garbled characters in it.

For example, on http://home.gna.org/auto-qcm/index.ja, you can see garbled characters "ホーム" in the <title> and text following "You are here", which are originally "ホーム". They seem to be converted to numeric reference of each byte of a UTF-8 string.

Hiroto Kagotani <khiroto>
Tue 04 Mar 2014 10:18:44 PM UTC, comment #6:

There are other websites that use SSI with no problem, so you can keep SSI.

I didn't have the time to investigate further but I'd like to reproduce the problem locally and see why auto-qcm's website in particular was impacted.

Beuc <beuc>
Site AdministratorIn charge of this item.
Tue 04 Mar 2014 05:32:50 PM UTC, comment #5:

Yes, the site was working properly before.
The other solution may be to rewrite my website to give up SSI. I found SSI useful, but I can do this work if we don't find any fix and prefer to keep deflate on.

Alexis Bienvenüe <jojo_boulix>
Mon 03 Mar 2014 09:57:56 PM UTC, comment #4:

As a work-around I can disable mod_deflate, but I don't want to do that since it doesn't explain the issue (and doesn't compress webpages traffic anymore).

I'm waiting for your feedback :)

Beuc <beuc>
Site AdministratorIn charge of this item.
Mon 03 Mar 2014 09:49:59 PM UTC, comment #3:

OK, apparently the webserver is mixing non-gzip'd (included subpages) with gzip'd (index.fr.shtml) content in its chunked answer. This looks like an Apache bug, unless there's a way to configure this away.

Beuc <beuc>
Site AdministratorIn charge of this item.
Mon 03 Mar 2014 09:37:01 PM UTC, comment #2:

Also, http://home.gna.org/auto-qcm/head appears to work fine.

Beuc <beuc>
Site AdministratorIn charge of this item.
Mon 03 Mar 2014 09:35:22 PM UTC, comment #1:

This may result from the upgrade.
I guess the website was working fine before?

I have troubles finding the source of the problem.
Using Firefox or Chromium yields an error, but curl doesn't complain nor wget (tested with both French and English).

Can you think of anything uncommon you used when working on the webpages?

Beuc <beuc>
Site AdministratorIn charge of this item.
Mon 03 Mar 2014 01:08:02 PM UTC, original submission:

The site http://home.gna.org/auto-qcm/ is no longer available, with "Content Encoding Error" on every pages (I use firefox, but the same error shows with chromium). However, the SVN was not modifed. Maybe it is related with home.gna.org reinstall on march 2.
Do you know if there is something special to be changed with the HTML files ?
Thanks!

Alexis Bienvenüe <jojo_boulix>

 

(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by khiroto (Posted a comment)
  • -unavailable- added by beuc (Posted a comment)
  • -unavailable- added by jojo_boulix (Submitted the item)
  • -unavailable- added by jojo_boulix
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 2 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Mon 03 Mar 2014 09:35:22 PM UTCbeucAssigned toNone=>beuc
    Mon 03 Mar 2014 01:08:02 PM UTCjojo_boulixCarbon-Copy-=>Added khiroto
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup