helpGCC Compile Farm - Support: sr #2863, Please install gcc 4.6.2 in...

 
 
Show feedback again

sr #2863: Please install gcc 4.6.2 in /opt/cfarm/gcc-core-latest

Submitted by:  None
Submitted on:  Wed 11 Jan 2012 09:46:39 PM UTC  
 
Category: NonePriority: 5 - Normal
Severity: 3 - NormalStatus: Done
Privacy: PublicAssigned to: Julien ÉLIE <iulius>
Originator Email: -unavailable-Open/Closed: Closed
Operating System: None

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Sun 28 Jul 2013 10:38:11 AM UTC, comment #20:

This issue was related to gcc14, gcc42, gcc49, gcc62, gcc64 and gcc66.
Everything has been fixed except for gcc64.

Now that gcc64 is definitely shutdown (read <https://mail.gna.org/public/gcc-cfarm-users/2013-05/msg00002.html>), this issue can probably be closed.

Julien ÉLIE <iulius>
Project AdministratorIn charge of this item.
Tue 29 Jan 2013 01:05:18 PM UTC, comment #19:

The exact error is in libgcc/config.log:
/home/iulius/autobuild/src/gcc-4.7.2/./gcc/cc1: can't load library 'libgmp.so.10.5' - you lost LD_LIBRARY_PATH.
Btw, I have no issues with cross-compiling gcc, actually, this is a preferred way. I do weekly builds of gcc-4.8 for hppa, ia64, mips and sparc machines. The slowest build takes less than 10 min on my old Core i5.

mik

Anonymous
Tue 08 Jan 2013 09:46:29 PM UTC, comment #18:

GCC 4.7.2 is now built on gcc42 and gcc49.
Still unsuccessful on gcc64 with:

./configure --disable-libstdcxx-pch --disable-nls --enable-threads=posix --disable-multilib --enable-languages=c,c++
and using CC='gcc -m64'

=> checking for suffix of object files... configure: error: in `/home/iulius/autobuild/src/gcc-4.7.2/sparc64-unknown-openbsd5.1/libgcc':
configure: error: cannot compute suffix of object files: cannot compile

Julien ÉLIE <iulius>
Project AdministratorIn charge of this item.
Thu 16 Aug 2012 03:21:26 PM UTC, comment #17:

This build is ok. Could you copy it and the dependencies to gcc49?
As for gcc64, one could to give a try ../gcc/configure --disable-libstdcxx-pch or if PCH support is really needed - CC=egcc CXX=eg++ ../gcc/configure

mik

Anonymous
Mon 18 Jun 2012 08:15:50 PM UTC, comment #16:

GCC 4.7.1 is built on gcc42.
Is /home/iulius/autobuild/bin/gcc-4.7.1/bin/gcc fine for you?

P.-S. : My last comment about the search for PCH support that fails is for gcc64.

Julien ÉLIE <iulius>
Project AdministratorIn charge of this item.
Sun 17 Jun 2012 08:25:02 PM UTC, comment #15:

Does it mean that, with the new 4.7.1 release, GCC does not need being patched any longer?

I have just tried to build it on gcc42 but building GCC 4.7.1 stops just after the search for a compiler with PCH support...

checking whether the /home/iulius/autobuild/src/gcc-4.7.1/./gcc/xgcc -shared-libgcc -B/home/iulius/autobuild/src/gcc-4.7.1/./gcc
-nostdinc++ -L/home/iulius/autobuild/src/gcc-4.7.1/sparc64-unknown-openbsd5.1/libstdc++-v3/src -L/home/iulius/autobuild/src/gcc-
4.7.1/sparc64-unknown-openbsd5.1/libstdc++-v3/src/.libs -B/home/iulius/autobuild/bin/gcc-4.7.1/sparc64-unknown-openbsd5.1/bin/ -B
/home/iulius/autobuild/bin/gcc-4.7.1/sparc64-unknown-openbsd5.1/lib/ -isystem /home/iulius/autobuild/bin/gcc-4.7.1/sparc64-unknow
n-openbsd5.1/include -isystem /home/iulius/autobuild/bin/gcc-4.7.1/sparc64-unknown-openbsd5.1/sys-include linker (/home/iulius
/autobuild/src/gcc-4.7.1/./gcc/collect-ld) supports shared libraries... yes
checking dynamic linker characteristics... cc1: warning: command line option '-nostdinc++' is valid for C++/ObjC++ but not for C
[enabled by default]
openbsd5.1 ld.so
checking how to hardcode library paths into programs... immediate
checking for exception model to use... call frame
checking for compiler with PCH support...

Julien ÉLIE <iulius>
Project AdministratorIn charge of this item.
Sat 28 Jan 2012 08:31:04 PM UTC, comment #14:

As I said, --build=mipsel-linux --enable-targets=all works only for trunk, the 4.6.2 release still needs to be patched.

mik

Anonymous
Thu 26 Jan 2012 08:32:31 PM UTC, comment #13:

Correction to #10:
s/using the -mabi= flag/using the -mabi=64 flag/
That's what I meant.

mik

Anonymous
Thu 26 Jan 2012 03:26:27 PM UTC, comment #12:

The configure scripts from gmp/mpfr/mpc try to guess a suitable abi for the host system, so -mabi=n32 is added to CLFAGS automagically, while gcc/configure lacks this magic.

mik

Anonymous
Wed 25 Jan 2012 09:16:36 PM UTC, comment #11:

When I do not use the -mabi= flag, configuring gcc fails with:

checking for the correct version of the gmp/mpfr/mpc libraries... no
configure: error: Building GCC requires GMP 4.2+, MPFR 2.3.1+ and MPC 0.8.0+.

Nonetheless, these three libraries were compiled with the same gcc flags (that is to say without the -mabi=flag). Strange I only manage to build gcc with "-mabi=n32".

I will try your suggestion of "--build=mipsel-linux --enable-targets=all".

Julien ÉLIE <iulius>
Project AdministratorIn charge of this item.
Tue 24 Jan 2012 11:00:40 PM UTC, comment #10:

According to gcc/config.gcc the default abi for mips64{,el}-linux is n32, so using the -mabi= flag has no sense unless you modify the config.
Btw, gcc from trunk can be configured as --build=mipsel-linux --enable-targets=all (then -lmpc -lmpfr -lgmp must be compiled for mipsel-linux too) or as --target=mipsel-linux --enable-targets=all (a cross-compiler) - in any case, patching is no longer required. Though I'm quite surprised that your mips64el-linux build did not support -mabi=64, while it should.

mik

Anonymous
Mon 23 Jan 2012 10:10:18 PM UTC, comment #9:

mik, I have just tried to build GCC 4.6.2 on gcc42 with "-mabi=64" but it failed with this error:

/home/iulius/autobuild/src/gcc-core-4.6.2/./prev-gcc/xgcc -B/home/iulius/autobuild/src/gcc-core-4.6.2/./prev-gcc/ -B/home/iulius/autobuild/bin/gcc-core-4.6.2/mips64el-unknown-linux-gnu/bin/ -B/home/iulius/autobuild/bin/gcc-core-4.6.2/mips64el-unknown-linux-gnu/bin/ -B/home/iulius/autobuild/bin/gcc-core-4.6.2/mips64el-unknown-linux-gnu/lib/ -isystem /home/iulius/autobuild/bin/gcc-core-4.6.2/mips64el-unknown-linux-gnu/include -isystem /home/iulius/autobuild/bin/gcc-core-4.6.2/mips64el-unknown-linux-gnu/sys-include -g -O2 -gtoggle -DIN_GCC -W -Wall -Wwrite-strings -Wcast-qual -Wstrict-prototypes -Wmissing-prototypes -Wmissing-format-attribute -pedantic -Wno-long-long -Wno-variadic-macros -Wno-overlength-strings -Wold-style-definition -Wc++-compat -DHAVE_CONFIG_H -static-libstdc++ -static-libgcc -o cc1 c-lang.o c-family/stub-objc.o attribs.o c-errors.o c-decl.o c-typeck.o c-convert.o c-aux-info.o c-objc-common.o c-parser.o tree-mudflap.o c-family/c-common.o c-family/c-cppbuiltin.o c-family/c-dump.o c-family/c-format.o c-family/c-gimplify.o c-family/c-lex.o c-family/c-omp.o c-family/c-opts.o c-family/c-pch.o c-family/c-ppoutput.o c-family/c-pragma.o c-family/c-pretty-print.o c-family/c-semantics.o c-family/c-ada-spec.o \
cc1-checksum.o main.o libbackend.a ../libcpp/libcpp.a ../libdecnumber/libdecn
umber.a ../libcpp/libcpp.a ../libiberty/libiberty.a ../libdecnumber/libdecnumb
er.a -L/home/iulius/autobuild/bin/gmp-5.0.2/lib -L/home/iulius/autobuild/bin/
mpfr-3.1.0/lib -L/home/iulius/autobuild/bin/mpc-0.9/lib -lmpc -lmpfr -lgmp -rdyn
amic -ldl -L../zlib -lz
/home/iulius/autobuild/bin/mpfr-3.1.0/lib/libmpfr.so: could not read symbols: Fi
le in wrong format
collect2: ld returned 1 exit status

Yet, I also built MPFR, GMP and MPC with the same "-mabi=64" flag given to the default gcc. Isn't it the right thing to do?

Everything works like a charm with "-mabi=n32".

Julien ÉLIE <iulius>
Project AdministratorIn charge of this item.
Wed 18 Jan 2012 07:10:14 PM UTC, comment #8:

Greetings! Just noting the default gcc (not in core-latest) does
support -mabi=64, so it seems sensible the core-latest build should
too.

Take care,

Anonymous
Wed 18 Jan 2012 07:05:16 PM UTC, comment #7:

The default abi on gcc42 is o32. If the target is mips{,el}-linux, gcc needs to be patched to support -mabi={64,n32}, this is how gcc is built and packaged by RAYS. A simplified patch is available in my ~ as /home/mik/src/gcc-on-rays.diff

mik

Anonymous
Wed 18 Jan 2012 06:39:41 PM UTC, comment #6:

There is /home/mik/misc/gcc-4.6/bin/gcc-4.6, it does supoort -mabi=64 (the default is -mabi=32).

mik

Anonymous
Wed 18 Jan 2012 06:35:22 PM UTC, comment #5:

> Greetings! -mabi=64 does not appear to be working on gcc-core-latest on gcc42 (mipsel64).


GCC 4.6.2 was built with the "-mabi=n32" flag on gcc42.

I did that owing to the recommendation "On mips64el-linux to compile default GCC, please use export CC="gcc -mabi=n32" and -with-mpfr=/opt/cfarm/mpfr-2.4.1-n32 --with-gmp=/opt/cfarm/gmp-4.2.4-n32 --with-mpc=/opt/cfarm/mpc-0.8-n32." That's why everything is with this flag.
Wasn't it the right thing to do for gcc42? (Linux mini PC / Debian mipsel)

Should it be built without any "-mabi" flag?

Julien ÉLIE <iulius>
Project AdministratorIn charge of this item.
Wed 18 Jan 2012 03:10:47 PM UTC, comment #4:

Greetings! -mabi=64 does not appear to be working on gcc-core-latest on gcc42 (mipsel64).

Anonymous
Fri 13 Jan 2012 10:45:30 PM UTC, comment #3:

Greetings! I was interested in gcc54/sparc64, and gcc61/hppa, both of which now appear to be fixed. Thanks!

Anonymous
Fri 13 Jan 2012 08:22:53 PM UTC, comment #2:

Additions to my previous comment:

  • I see that gcc62 still has 4.6.1. Building 4.6.2 is in process.
  • gcc64 has neither 4.6.1 nor 4.6.2. Still in search for the right configure options to use. Maybe using a more recent binutils chain is needed for gcc64, as mik suggested in ticket #2780.
Julien ÉLIE <iulius>
Project AdministratorIn charge of this item.
Fri 13 Jan 2012 08:02:29 PM UTC, comment #1:

GCC 4.6.2 was already installed in /opt/cfarm/gcc-core-latest for almost all servers. (It is still missing from gcc66, the most recent server added to the farm. Building is in progress, though. And due to the low memory available on gcc38, it has not been built there.)

As far as I can see, the 4.6.1 build was only mentioned on gcc14, and it is now fixed.
Did you have a particular server in mind when opening your ticket? Do not hesitate to tell if you see something wrong.

Also, the 4.6.2 build is gcc-core (meaning only the C language front end). Is it OK for your need or do you want other languages as well?

Julien ÉLIE <iulius>
Project AdministratorIn charge of this item.
Wed 11 Jan 2012 09:46:39 PM UTC, original submission:

... of course when time permits. Thank you so much for the 4.6.1 build!

Anonymous

 

(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by guerby (Updated the item)
  • -unavailable- added by iulius (Posted a comment)
  • -unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 4 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sun 20 Apr 2014 06:01:39 PM UTCiuliusStatusIn Progress=>Done
      Open/ClosedOpen=>Closed
    Thu 16 Aug 2012 04:08:18 PM UTCguerbyStatusNone=>In Progress
      Assigned toNone=>iulius
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup