helpGna! Administration - Support: sr #655, Using bazaar instead of tla (Was:...

 
 
Show feedback again

sr #655: Using bazaar instead of tla (Was: No categories are showing up for my archive in ArchZoom)

Submitted by:  Joshua Root <tesseract>
Submitted on:  Mon 01 Aug 2005 04:04:02 PM UTC  
 
Category: SCM: Arch RepositoriesPriority: 5 - Normal
Severity: 3 - NormalStatus: Done
Privacy: PublicAssigned to: Mathieu Roy <yeupou>
Open/Closed: ClosedOperating System: Any / Non-Specific

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Wed 07 Sep 2005 07:45:11 AM UTC, comment #12:

Excellent, thanks!

Joshua Root <tesseract>
Wed 07 Sep 2005 06:46:22 AM UTC, comment #11:

Baz as been installed and archzoom set to use it.

Mathieu Roy <yeupou>
Site AdministratorIn charge of this item.
Mon 29 Aug 2005 09:35:17 AM UTC, comment #10:

There is no problem having baz and tla installed at the same time. But if archzoom is the only thing using tla on the server, then tla will no longer be needed after baz is installed.

Archzoom will need to be reconfigured: in archzoom.conf, arch_backend should be set to baz rather than tla.

IMHO, Bazaar-NG is irrelevant to the current discussion, since (a) it is not in Debian Stable, (b) archzoom cannot use it, and (c) it does not work with existing archives which are in the baz or tla format.

Joshua Root <tesseract>
Mon 29 Aug 2005 09:05:55 AM UTC, comment #9:

bazaar is a fork of tla, and is therefore a complete replacement.

FYI, tla is not maintained anymore. baz will soon be deprecated in favor of bzr (aka Bazaar-NG aka Bazaar 2).

Matthieu MOY <moy>
Mon 29 Aug 2005 08:48:10 AM UTC, comment #8:

Ok, we'll check.

I'm not familiar with arch. Was does it mean exactly? We have to replace tla by bazaar or just to add bazaar?

Mathieu Roy <yeupou>
Site AdministratorIn charge of this item.
Fri 19 Aug 2005 04:56:19 PM UTC, comment #7:

Bazaar does seem to be in Debian stable:
http://packages.debian.org/stable/devel/bazaar

I believe the version of ArchZoom which is already on arch.gna.org can use baz as well as tla.

Joshua Root <tesseract>
Thu 18 Aug 2005 04:45:10 PM UTC, comment #6:

I've learned today that the main maintainer of tla quitted his position of GNU Arch maintainer and recommends to use bazaar instead of tla.

I guess people will have to use --tla option until debian provide updated packages.

Mathieu Roy <yeupou>
Site AdministratorIn charge of this item.
Tue 09 Aug 2005 04:59:39 PM UTC, comment #5:

- It's unlikely that we switch from tla to something else on the server.
- Using packages not shipped by debian stable is not going to happen unless it's really proves to be necessary. Content shown in archzoom does not impact the usefulness of the development tool itself.

Mathieu Roy <yeupou>
Site AdministratorIn charge of this item.
Tue 09 Aug 2005 01:30:41 AM UTC, comment #4:

OK, fair enough. Is there a feature request open for installing baz on the server, or should I create one?

Also, in the meantime, perhaps the FAQ entry about the Arch server should be updated to include this information?

Joshua Root <tesseract>
Mon 08 Aug 2005 02:51:53 PM UTC, comment #3:

According to

http://arch.gna.org/tourney/2005-work/.archive-version

You have the same problem as me (bazaar archive).

Matthieu MOY <moy>
Mon 08 Aug 2005 02:20:08 PM UTC, comment #2:

I had the same problem.

The problem was that my archive was using the bazaar format (which is also the default since stg like tla 1.3.2). The solution would be to upgrade the installation of tla on gna's server, or install bazaar (I'd recommand the later, since tla 1.x development is mostly dead).

In the meantime, creating the mirror with "baz make-archive --tla" solved the problem.

Matthieu MOY <moy>
Mon 01 Aug 2005 04:12:02 PM UTC, comment #1:

Wow, some of that really got messed up by the automatic link detection. I'm attaching the original message as plain text.

Joshua Root <tesseract>
Mon 01 Aug 2005 04:04:02 PM UTC, original submission:

I have mirrored the archive for tourney, tla didn't report any errors, and browsing the directory it looks like everything is OK [1]. ArchZoom sees that there is an archive for tourney [2], but it doesn't show any categories in that archive [3].

The commands I used to make the mirror were "tla make-archive --listing --mirror thorondor@iinet.net.au--2005-work sftp://tesseract@arch.gna.org/upload/tourney/2005-work" followed by "tla archive-mirror thorondor@iinet.net.au--2005-work tourney". This is exactly what the FAQ says to do except that I limited the mirror to the "tourney" category since I have other projects in the same local archive.

[1] http://arch.gna.org/tourney/2005-work/
[2] http://arch.gna.org/known-archives/tourney
[3] http://arch.gna.org/archzoom/thorondor@iinet.net.au--2005-work

Joshua Root <tesseract>

 

(Note: upload size limit is set to 1024 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files
file #427:  msg.txt added by tesseract (811B - www/unknown - original mesage as plain text)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by yeupou (Posted a comment)
  • -unavailable- added by moy (Posted a comment)
  • -unavailable- added by tesseract (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 6 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Wed 07 Sep 2005 06:46:22 AM UTCyeupouStatusConfirmed=>Done
      Assigned toNone=>yeupou
      Open/ClosedOpen=>Closed
    Mon 29 Aug 2005 08:48:36 AM UTCyeupouSummaryNo categories are showing up for my archive in ArchZoom=>Using bazaar instead of tla (Was: No categories are showing up for my archive in ArchZoom)
    Mon 29 Aug 2005 08:48:10 AM UTCyeupouStatusNone=>Confirmed
    Mon 01 Aug 2005 04:12:02 PM UTCtesseractAttached File-=>Added msg.txt, #61
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup